After the new update kde is sending anything I click to trash

After the recent update kde started deleting files on mouseclick.

I logged out of kde and went on bspwm. I did notice it when I used my wireless mouse but later it worked fine.

But on kde using trackpad mouse but mouse buttons gave the same result.

I look for terminal output in dolphin and it said:
dolphin kf.kio.core: "Could not enter folder tags:/." kf.kio.core: "Could not enter folder tags:/." kf.kio.core: We got some errors while running testparm "Error loading services." kf.kio.core: We got some errors while running 'net usershare info' kf.kio.core: "Can't load /etc/samba/smb.conf - run testparm to debug it\n" Cannot initialize model with data QJsonObject() . missing: QJsonValue(string, "urls") "The file or folder /home/nirvash/Desktop/txt/claw does not exist." "The file or folder /home/nirvash/Desktop/txt/claw does not exist." "The file or folder /home/nirvash/Desktop/txt/claw does not exist." ^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3~^[[3

So the output here keyspam in the end and it stopped once I clicked the button again.

Sorry I tried posting image but apparently I cannot post embed items. wow

I checked logs with journalctl:

I mostly noticed multiple lines like this :
plasmashell[7796]: file:///usr/lib/qt/qml/QtQuick/Controls/Styles/Plasma/ToolButtonStyle.qml:196:13: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }

I’m guessing this is the message I’m getting when I click any file and it goes to the trash:

        plasmashell[7796]: "The file or folder /home/nirvash/Desktop/icllou.txt does not exist."
    Oct 03 09:56:05 nirvash-pc kwin_x11[7752]: file:///usr/share/kwin/aurorae/MenuButton.qml:22: TypeError: Cannot read property 'closeOnDoubleClickOnMenu' of null
    Oct 03 09:56:05 nirvash-pc kwin_x11[7752]: file:///usr/share/kwin/aurorae/MenuButton.qml:22: TypeError: Cannot read property 'closeOnDoubleClickOnMenu' of null
  1. What do you mean? It doesn’t happen when you’re using bspwm and that’s your current workaround?

  2. So it only happens in Dolphin? Does it also happen when you create a new user and log in there?

  3. We’re sorry but that’s to keep spammers out. Please read this


Whenever I click with the mouse the file got sent to the trash. It happened with any file regardless of file manager. It also happened with thunar.

And I would get multiple messages on screen saying the file I clicked on does not exist. This got real awful. I logged out of kde. I took a pic of the notification on screen.

Bspwm did not exhibit this. I don’t know what’s causing it in kde.

I’ve desperately searching for answers on reddit and this forum. But mostly none bothered.

Bspwm did not exhibit any of this. That seems like a workaround.

  1. Not good… :scream:

  2. Please note you haven’t responded to this:

  3. If the screenshot provides additional information, please provide one. If it doesn’t: no need

  4. Please also use numbers when responding as this greatly increases the efficiency of responses.

:stuck_out_tongue_winking_eye: :grin:

1)Oh no I’m worried.

  1. I created a new user and logged in. I did not notice any odd stuff. Nothing is moved to trash on click.
  1. No it doesn’t have any info. That’s why I put the log in my post. That was the message. But 40 notifications popped on screen to say the file doesn’t exist. That’s why I tried to put the image. But the log is enough.
  1. I will.
1 Like

OK, so you have a profile issue and it’s going to take days if not weeks to find out exactly what you did in the current profile for it to be messed up like that. :man_shrugging:

Therefore, we’re going to do the following:

  • Verify that the new user has access to the same groups as your old one by executing groups and comparing the output of both users.

    groups fullmetal
    groups fullmetal2

    (Where obviously, fullmetal is your old user and fullmetal2 is your new one.)
    E.G. if fullmetal is a member of operator and fullmetal2 isn’t, execute:

    sudo usermod --append --groups operator fullmetal2 
  • Copy all data files from your old profile into your new one

    cp --verbose --recursive --preserve=time-stamps /home/fullmetal/Documents/* /home/fullmetal2/Documents/
  • If that worked and you had no errors, remove the documents from your old user:

    rm --recursive /home/fullmetal/Documents/*
  • repeat for:

    • Pictures
    • Videos,
    • Music,
    • .thunderbird,
    • .mozilla/firefox/,
    • Templates, and everything else that is important to you.
    • Linux games like Battle of Wesnoth have their game data stored under .local/share/ E.G. .local/share/wesnoth
  • After everything has been copied over, disable the old user so you cannot accidentally log on:

    usermod --lock fullmetal
  • If you would have theming going on, don’t do everything in one day but do this at the rate of 1 application / theme / whatever per day and if the problem crops up again, roll back your last change

  • in 1 month delete the entire home directory of your old user, but don’t delete the user itself so that in 6 months time files still owned by that user will still show up under its username.

  • If you ever migrate to a new machine, just don’t migrate the old user: only the new one.

  • From now on, start making backups so you can roll back and never have to do this again:


1)I am no poweruser. I did not mess with any settings. The main account has access to some default groups. I logged back into my main account and changed the theme. I don’t see nothing odd that has happened after that.

2)But I don’t know if I can just delete this account. I only have a 1 tb external harddrive. I don’t have NAS or anything. I will backing up slowly.

3)I don’t have themes or anything. But I have some old games in wine. And documents. I will move the docunents.

4)Bottomline I still want to know where to look about this problem. If I give up learning to fix I will never learn. As of now I don’t see any exhibits. But I will still like to understand what happened.

Maybe create a new user on your box and see if that works as intended. Then you can try to figure out why your other user misbehave.

I would create one definitely. I will be slowly migrating my documents to a backup. Meanwhile I will keep the user account with minimal stuff.

I logged back into my main account and changed the theme. I dunno nothing odd happened. But I’m vigilant.

The thing is I still don’t know what caused this. I wanna dig into this and know what happened. But I don’t know where to look first.

  1. Did you ever shut down the computer by pressing the power button >5 seconds? That one is seriously messing with stuff… :wink:

  2. No! Don’t delete the account! just follow the instructions and copy everything over from the old account to the new one and then disable the old one

  1. Good! :+1:
  2. OK, well you now:
    • know it’s something in your old user profile / account settings
    • you now also have a working new profile / account,
    • so please follow instructions above, copy your valuable data over to the new account.
    • while you now work in your new user account without having your files being deleted when you click them, *you can compare all settings one by one between the two profiles.

List of directories to compare:

  • ~./local
  • ~/.config


That’s what we already did: the new user does not have this weird behaviour and why I’m asking to copy his/her data over to the new account as a simple click seems to delete his/her data and you know I’m Mr Backup here so rather paranoid about data loss and why I started helping OP in the first place… :stuck_out_tongue_winking_eye:

Hey there. I have copied documents, downloads, pictures and desktop so far. I still have certain doubts.

  1. I have copied my essential stuff like mozilla. Is that ok? Can I copy my keepass xc stuff and thunderbird? These are hidden folders but they are not in config or local. Do I need to copy files from local or config for those apps?

  2. What should I do about steam/proton, wine and lutris? How do I have to copy them? What folders should I copy?

Sorry I’m asking this late but I’m flustered.

  1. Mozilla FireFox:

     sudo cp /home/fullmetal/.mozilla/firefox/* /home/fullmetal2/.mozilla/firefox/


     sudo cp /home/fullmetal/.thunderbird/* /home/fullmetal2/.thunderbird
  2. I don’t have those, but the principle is the same: copy the directories from your home directory to your new user. E.G. For Battle of Wesnoth (Which I have:)

    sudo cp /home/fullmetal/.local/share/wesnoth/* /home/fullmetal2/.local/share/wesnoth/

No worries: report back:

  • If you run into additional issues
  • when you’re done and it all worked.


  1. I’ll be editing the original answer to include anything you ask additionally so that the next user that has the same problem as you has a robust procedure to follow.
  2. You’re learning about your system! You’ll be a better hacker able to sort out more issues after you"re done and will be in a better position to take good backups in the end!
  3. If you’re in need of a laugh and more basic Linux information, read this when you get frustrated again:


Ok. I did what you said. I slowly copied stuff to the new user. But now the problem came back as I’m typing this. I’m really clueless and stuck.

What was the last thing you copied?

If you used the terminal, what’s the output to:

history | tail --lines=25


  1. Last I copied my wine folder and folders I sync with my phone.

  2. Here is the weird thing. I copied stuff using terminal commands. But the history is not showing them. The stuff I see is old. Commands used to copy wine was not there.

  3. This is another weird thing. When I boot my system grub shows two entries of manjaro. One says manjaro linux. Another entry says manjaro linux 20.1.1 on dev/sda. What is happening?

  1. So the culprit is somewhere in there! I you copy hidden directories (starting with a .) they generally contain settings and one of those is what’s causing the errant behaviour.
    Delete those and see if that makes the problem disappear, then copy them more carefully (directory per directory)
  2. Did you close the terminal with exit or Ctrl+D before shutting down your machine? If not you did this:

    So you sent a SIGKILL to the console instead of a SIGINT and it didn’t have time to save the history.
  3. That would be a new topic all on its own… :sob:
  1. Ok I will delete that.
  2. Ok my laptop died of low battery. That is prolly it.
  3. Oh no.(。•́︿•̀。)
1 Like