After the login screen the display just turns black and the monitors show “no signal”


I am new to the forum and am at a loss and would appreciate some input on how to solve the following situation:

System specs:

CPU: AMD Ryzen 9 5950X
RAM: 32 GB
2 x monitors connected via Displayport/HDMI

Distro info:
Manjaro 21.0.2 Stable Gnome Edition encrypted with LUKS
Kernel: 5.10 & 5.11
Proprietary NVIDIA drivers

I updated to the latest stable update on Monday and I didn’t see any error messages. Manjaro was running just fine. When I rebooted into Manjaro I got to the login screen and the monitors displayed the login screen correctly. I logged in and then the monitors just turned black and the monitors displayed that there was “no signal” coming in. The system seemed to be running though; the system didn’t automatically reboot. I had to manually turn the power off.

Since I couldn’t find any info about this particular problem in the “Stable Update” thread and I needed a working install I decided to just reinstall Manjaro and be up and running again.

I downloaded the latest Manjaro iso and installed the OS without any problems and turned the PC off again. But the next day I could only get to the login screen again. After I correctly put in my password the monitors again displayed that there was “no signal”. I then again got the latest iso and installed it because I thought that perhaps there was a problem with my iso download. After another install I just got the same problem.

On the system I am also running Windows 10 on another drive and there I don’t have any display issues. The monitors work fine. I even tried a different Displayport cable or used HDMI but that didn’t change the situation. So in my newbie opinion it has to be software problem.

Since I can’t get into my Manjaro install I can’t really provide an error code or detailed system info. But I would appreciate a tip or suggestion from a Manjaro veteran to a Manjaro noob on how I could fix this. Thanks for the help! :slight_smile:

Hi and welcome to the forum :wave:

If you do a install with open source drivers does the same problem occur?

Tip how to gracefully reboot a stuck system, admittedly this is only usefull after solving the black screen issue.

1 Like

:+1: Welcome to Manjaro! :+1:

Is Windows fast start turned off and do you cold boot going from Windows to Manjaro?
(From Manjaro to Windows you can still warm boot.)

Does this also happen if you log into a newly created user (E.G. somerandomguy2)

Yes, you can: Ctrl+Alt+F2 is your friend and once you log in there you can give us an

inxi --admin --verbosity=7 --filter --no-host --width

which is the minimum required information for us to help you… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that it looks like the above.


Thank you both for your suggestions and help! :slight_smile:
The GPU started to behave iffy on Windows as well so I borrowed another Nvidia GPU from one of my mates. I reinstalled the system with this other GPU and I didn’t get that weird problem with this GPU. So for the time being I guess it was a hardware issue and not a software problem. Once I get a new GPU from my vendor I will give it another test and see what happens. Thanks for helping me out! :slight_smile:

This question has been closed administratively as the problem was:

  • a hardware problem
  • solved by replacing the faulty hardware.
1 Like