After the large update some days ago, Opera has refused to minimize from the top right corner of the window

I’m using Plasma, and after the large update a few days ago, my Opera browser started to just flash down into minimized state for a minuscle moment and then reappear back where it was upon a minimize attempt. This happens when I try to minimize Opera’s window to the task bar from the minimize button in the corner. It happens both in maximized and non-maximized windows. The only way I can minimize Opera is to click on its icon on the taskbar.

Re-install didn’t help. It’s more annoying than debilitating, but I’ll gladly take any ideas on how to solve this.

Create a Window Rule for it, like this

It will integrate better in KDE Plasma. You can disregard the Activities entry if you do not use them.

Well, not quite the solution I was expecting, but works for me. :+1:

Also, thanks for letting me find a new bunch of settings I can now toy with to get to know them. :star_struck:

1 Like

You can also try adding “focus capture prevention” rule… force + extreme.
If it works, this will prevent window decoration.

(works for me)


Also works for me, thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.