After the installation of kernel headers the computer keeps hanging at boot

My laptop runs on 5.15.28-1 kernel. I was getting ready to install waydroid. i needed to install two kernel modules (ashmem and binder). In order to do so, I had to install the kernel headers. After I did so, I noticed it was getting late, so I decided to stop and to continue the next day. Then I shut down the computer.
The next day, I switched on my laptop. It showed the asus logo, then the grub menu. After the grub countdown, it showed again the asus logo and it kept showing it. After 5 minutes, I forcibly rebooted the computer. When it rebooted, it hung once again in the same way as before.
Then I begun looking for a solution on the internet. I found this thread: Failed to start Load Kernel Modules and this thread: [solved] Boot : failed to start load kernel module . The problems they solved weren’t the same as mine, but they gave me a hint.
I made a manjaro live usb stick, booted from it and ran manjaro-chroot as root. Then I removed the headers, as it was the last thing I did before the issue appeared. Then I rebooted the computer from its internal HDD. It ran as usual and everything worked fine.
In order to install those two modules, I tried other kernels. Every one of them worked fine until I installed the headers. Every time it would keep hanging until I removed the headers.
I can’t find any solution to this issue on the internet.

My laptop is a Asus Zenbook UX303LA, it has an Intel Core i7-4510U , 12GB of RAM, and an Intel HD 4400 integrated graphics adapter. It has a dual boot configuration (Manjaro Linux and MS Windows 11). As a shell, I use zsh.

P.S: I’m sorry that I probably killed the English language, but it isn’t my native language.

Update: I was asked to run inxi and to post its output. Here it is:

pietro@mostrocomputer ~ » inxi --admin --verbosity=7 --filter --no-host --width     
  Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.15-x86_64
    root=UUID=d1d27617-65ae-4d6b-bb52-f2fc4b26efb2 rw rootflags=subvol=@ quiet
    udev.log_priority=3 resume=UUID=9e6069fd-7b57-4613-acb1-e150346efca6
  Desktop: MATE v: 1.26.0 info: mate-panel wm: marco v: 1.26.0 vt: 7
    dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: UX303LA v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: UX303LA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: UX303LA.206 date: 04/18/2019
  ID-1: BAT0 charge: 36.8 Wh (98.1%) condition: 37.5/50.1 Wh (74.9%)
    volts: 11.3 min: 11.3 model: ASUSTeK UX3-44 type: Li-ion serial: N/A
    status: not charging cycles: 251
  RAM: total: 11.58 GiB used: 2.87 GiB (24.8%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-4510U bits: 64 type: MT MCP arch: Haswell
    family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1632 high: 1996 min/max: 800/3100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 817 2: 1996 3: 1722
    4: 1996 bogomips: 20759
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
    rdtscp rep_good sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: ASUSTeK driver: i915
    v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:0a16 class-ID: 0300
  Device-2: Suyin Asus Integrated Webcam type: USB driver: uvcvideo
    bus-ID: 1-5:2 chip-ID: 064e:9700 class-ID: 0e02 serial: <filter>
  Display: x11 server: v: compositor: marco v: 1.26.0 driver:
    X: loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1600x900 s-size: <missing: xdpyinfo>
  Monitor-1: eDP-1 model: Chungwa Picture Tubes 0x17db built: 2012
    res: 1600x900 hz: 60 dpi: 139 gamma: 1.2 size: 293x164mm (11.54x6.46")
    diag: 336mm (13.2") ratio: 16:9 modes: 1600x900
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel v: kernel
    bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:08b1 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-8:3 chip-ID: 8087:07dc class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 238.47 GiB used: 119.72 GiB (50.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD6SB1M256G1002
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 600 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 114.95 GiB size: 114.95 GiB (100.00%)
    used: 74.31 GiB (64.6%) fs: btrfs dev: /dev/sda6 maj-min: 8:6 label: N/A
    uuid: d1d27617-65ae-4d6b-bb52-f2fc4b26efb2
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 32 MiB (33.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: SYSTEM
    uuid: D691-1B64
  ID-3: /home raw-size: 114.95 GiB size: 114.95 GiB (100.00%)
    used: 74.31 GiB (64.6%) fs: btrfs dev: /dev/sda6 maj-min: 8:6 label: N/A
    uuid: d1d27617-65ae-4d6b-bb52-f2fc4b26efb2
  ID-4: /home/<filter>/onedrive.bicocca raw-size: N/A size: 1024 GiB
    used: 4.57 GiB (0.4%) fs: fuse.onedriver source: ERR-102
  ID-5: /home/<filter>/onedrive.personale raw-size: N/A size: 5 GiB
    used: 205.4 MiB (4.0%) fs: fuse.onedriver source: ERR-102
  ID-6: /var/cache raw-size: 114.95 GiB size: 114.95 GiB (100.00%)
    used: 74.31 GiB (64.6%) fs: btrfs dev: /dev/sda6 maj-min: 8:6 label: N/A
    uuid: d1d27617-65ae-4d6b-bb52-f2fc4b26efb2
  ID-7: /var/log raw-size: 114.95 GiB size: 114.95 GiB (100.00%)
    used: 74.31 GiB (64.6%) fs: btrfs dev: /dev/sda6 maj-min: 8:6 label: N/A
    uuid: d1d27617-65ae-4d6b-bb52-f2fc4b26efb2
  ID-8: /windows raw-size: 110.51 GiB size: 110.51 GiB (100.00%)
    used: 40.81 GiB (36.9%) fs: ntfs dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 2A2E95A02E95661B
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 12 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda5 maj-min: 8:5 label: N/A
    uuid: 9e6069fd-7b57-4613-acb1-e150346efca6
  ID-1: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/sda4 maj-min: 8:4 size: 916 MiB fs: ntfs label: N/A
    uuid: 705C5E205C5DE200
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 9 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-5:2 info: Suyin Asus Integrated Webcam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 064e:9700 class-ID: 0e02 serial: <filter>
  Device-2: 1-8:3 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:07dc class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 40.0 C pch: 38.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2300
  Processes: 243 Uptime: 13m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: apt: 0 pacman: 1558 lib: 453
  Shell: Zsh v: 5.8.1 running-in: mate-terminal inxi: 3.3.14

Maybe the update is interrupted.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Installing the kernel header will do nothing on itself, it is just files.

Post the complete terminal output of you installing the kernel headers. We might see what happens. I have an idea of what it could be but only logs could help to know.

1 Like

When I installed the headers before, I used pamac (the GUI version). Now I did it like I did then.
Here is the pamac output:

Sincronizzazione database dei pacchetti...
Aggiornamento DEB_Arch_Extra.db...
Risoluzione delle dipendenze...
Controllo conflitti tra i pacchetti...
Controllo portachiavi...
Verifico l'integrità dei pacchetti...
Caricamento dei file dei pacchetti...
Controllo conflitti tra file...
Controllo spazio disponibile su disco...
Installazione linux515-headers (5.15.28-1)...
Esecuzione post-transaction hooks...
Arming ConditionNeedsUpdate...
Updating module dependencies...
Install DKMS modules
È richiesto un riavvio per completare le modifiche.
Transazione completata con successo.

Now I’ll try rebooting to see what happens.

Now, strangely enough, it worked fine.

I still see two weird things

Aggiornamento DEB_Arch_Extra.db...

This is not Manjaro repository, you added an external repository and you didn’t tell anyone in the thread.

Also you apparently have DKMS installed trying to install modules for the kernel, this was my guess on what was breaking your system.


I didn’t notice it before. It was presumably added when I installed MEGAsync, since it contains MEGA related stuff.

Is it a serious issue? How could I solve it?

That’s not an issue on itself, but that means you installed something that required DKMS. This could be an issue depending on what DKMS is building, if it works or not. Apparently it is not building anything here.

Just curious where you installed megasync from? Its in the aur so shouldn’t need any external repos

I installed it from their website. I completely forgot to look for it in the AUR (I’m both absent-minded and new to Manjaro)

My Linux knowledge isn’t the best either but I know installing from websites rather than official repos/aur can cause issues on manjaro. I don’t think its anything to do with your issue though