After -Syu today, pcmanfm won't launch

After Manjaro upgrade today pcmanfm won’t launch. Tried to launch from terminal with this error - (pcmanfm:83226): Gtk-WARNING **: 14:59:13.692: Unable to locate theme engine in module_path: "murrine"

Been using pcmanfm for months so not sure why I would need to install gtk-engine-murrine for it to keep working, but I did. Pcmanfm still won’t launch. However it no longer generates that error message, or any error message for that matter.

Anyone experiencing this?

Updated packages list:

`Packages (12) archlinux-appstream-data-20201020-1`


`linux-firmware-20201120.r1785.bc9cd0b-1 linux54-5.4.78-1`

`linux59-5.9.10-1 linux59-headers-5.9.10-1`

`manjaro-release-20.2rc-1 pamac-common-9.5.12-2`

`telegram-desktop-2.4.11-0.1 timeshift-20.11.1.r1.g3391f69-3`



I reverted to yesterday’s timeshift snapshot so I can keep using pcmanfm until this is sorted. Thanks for any input.

@oberon and I could not reproduce this, it launches fine.

It shouldn’t be required unless the GTK2 theme you’re using requires it.

None of those packages are related.

I just rebuilt it along with a patch we were missing in our overlay. It’s currently only pushed to unstable. You can download it here: pcmanfm 1.3.1-2.1

Either way, you may also want to try pcmanfm-gtk3.


Thank you. I’m a bit confused, I did the update again and cannot reproduce the issue myself.

There was a kernel update did you reboot?

1 Like

Well, that’s good. Also I never would have noticed the patch was missing unless you had posted, so it all worked out. :+1:

1 Like

I was able to reproduce the problem. It seems I had not provided all of the information.

The only other thing I had done after the update was to install and run Qtile, hacking on the config a bit.

Today I went back to Qtile for more of the same. Back to AwesomeWM and the exact same issue is back. No idea if this is any more useful to you guys.

It’s either directly related to Qtile or something in DT’s config for it, as far as I can tell. I will reboot and see if it goes away.

UPDATE: Rebooting did fix it. I was not able to reproduce it by switching to Qtile (and back) again. I have to say I have rebooted since the update so that is not it. I took out about half of the so might have removed something that made it bug out. Forever a mystery haha