After restart all folders and files in one spot

I use Manjaro Cinnamon before restart I see this:


after restart all these files and folders in red color are in this spot:

Perfect.

Win10 doesn't have something this comfortable. Cool.

Whereby, I haven't seen Win10 for ages :smiley:

Are you using multiple monitors?
What are your settings for the desktop icons? right click on the desktop and the popup will give you the link to the settings.

Are you using multiple monitors?

no, I have one 4k monitor.
Where Can I find desktop icons settings? Could you write direct path to the icons settings?

Are you talking about this window:

That looks ok.

Is nemo-desktop running?
ps -ef | grep nemo

As a last try you could reset all cinnamon settings and see if that fixes it:
gsettings reset-recursively org.cinnamon

ps -ef | grep nemo
1615  1105  0 08:38 ?        00:00:31 nemo-desktop
7024     1  0 15:14 ?        00:00:02 nemo /home/mmm/Desktop/Gutenberg Blocks for WordPress and React Developers
8749  8742  0 15:29 pts/1    00:00:00 grep --colour=auto nemo

but I don't think that reset all cinnamon settings is a good idea.

Are the desktop icons working for a different user? Can you just create a test user and check?

any thoughts guys?

maybe you click multiple desktop?
have you check desktop folders and files in file explorer (mine: dolphin KDE)? it is gone?

No multiple desktops:

No, I mean linux have multiple desktop (desktop 1, 2, etc) feature not multiple monitor
aaa

the box beside manjaro logo in my KDE

and check in file explorer
desktop

I turned off Workspaces, but I got this after restart:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

I use Manjaro Cinnamon before restart I see this:


after restart all these files and folders in red color are in this spot:

I thought that I solved this problem, but this problem appear now again.

Seriously ... this is the 3rd time you posted about this. First two posts got merged and you marked this as solution. Isn't working anymore following the same advice?

1 Like

This solution is a bad solution. It didn't work anymore.

Please provide Customize of your desktop when you right click. Should look like this:

image

and the output terminal for:
gsettings get org.nemo.preferences desktop-is-home-dir
and
cat ~/.config/user-dirs.dirs

By any chance do you use nautilus too instead of nemo as File manager? Then share:
gsettings get org.gnome.nautilus.preferences desktop-is-home-dir

$ gsettings get org.nemo.preferences desktop-is-home-dir
false
$ cat ~/.config/user-dirs.dirs
# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run.
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
# 
XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

I use Nemo 4.2.3

Turn on Auto-arrange.

Forum kindly sponsored by