After removing my SSD to test a backup, the Manjaro bootloader is no longer showing up in boot menu (but works when detecting EFI bootloader using Manjaro live)

Hello, I took out my SSD to test a backup (which didn’t work - that is a separate issue).

When I put the SSD back in, my Manjaro grub bootloader menu doesn’t show up anymore. Only my Windows one does (which just loads Windows 10).

When I boot to Manjaro live and run the “detect EFI bootloaders” option, it shows two of the Manjaro options which both load fine / I can load my Manjaro system fine with them so that is good.

How do I go about restoring the Manjaro bootloader option to the boot menu?

Sorry if I’m not using the right terminology here, I think I’m mixing up bootloader but maybe not.

This is what my SSD partitions look like.

You could try the following… Open up a terminal in the live session and enter the following commands… :arrow_down:

sudo su -
manjaro-chroot -a
grub-install --recheck --removable
1 Like

Thank you for the response!

When I run the grub-install command I get this error:

grub-install: error while loading shared libraries: cannot open shared object file: No such file or directory

If you don’t have any zfs volumes, then I’d simply ignore that warning. :man_shrugging:

I don’t have zfs volumes as far as I know.

But it seems like the command isn’t doing anything because of that error.

Same with if I type in update-grub it gives this error:

/usr/bin/grub-probe: error while loading shared libraries: cannot open shared object file: No such file or directory

Hmm… I think it may be because the kernel of the live system was built with zfs support in it. You could try by adding the --skip-fs-probe and --force options to grub-install. :arrow_down:

grub-install --recheck --removable --skip-fs-probe --force

Don’t mind update-grub ─ you don’t really need that step at this point. :thinking:

Even with those new options it is giving the same shared libraries error, very weird!

But have you rebooted yet and checked whether it worked?

Just rebooted but it still isn’t showing up as an option in the boot menu.

This sounds more like a problem to do with the EFI boot variables in NVRAM anyway. I would suggest booting into the UEFI settings and seeing if you can add the drive back as an active boot device.

I personally don’t have that much experience with UEFI yet, so I’ll ping someone who does. If you cannot do it from within the UEFI settings, then he might be able to talk you though the use of efibootmgr.


If you can use the “detect EFI bootloaders” option from a live ISO, then you should be able to boot into your installed system and run the grub-install command from there without chroot.

1 Like

I ended up fixing this by fixing the libzfs issue, which then let me run grub-install and update-grub which fixed the bootloader.

For anyone who runs into the error, I ran these commands:

sudo ln -s /usr/lib/ /usr/lib/

sudo ln -s /usr/lib/ /usr/lib/

After that I ran sudo grub-install --recheck --removable and then sudo update-grub and then restarted my computer.

Thank you for the help! I was also able to get my backup/clone I made to work as well using your instructions @Aragorn


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.