After pacman -Syu, selecting Manjaro on Grub just returns an infinite loading screen

On an Asus laptop. After selecting Manjaro Linux on grub (dual-boot windows) it shows the ASUS logo, with the manjaro logo underneath, and then the manjaro logo disappears and it stays infinitely stuck on the ASUS logo. I notice that I can only switch between tty’s in the initial loading, when the manjaro logo is up. I looked up which packages I upgraded and gdm seemed guilty, which was upgraded from version 3.38-3.40. So I downgraded both gdm and libgdm to version 3.38, despite having all other gnome apps current, and it still didn’t work. I tried using lightdm, and it showed up the error on boot, since I forgot to install a greeter, so it means it is trying to load something. After installing the greeter the same ASUS logo infinite loop issue happened again. I noticed that during the manjaro logo + ASUS logo boot phase I can switch ttys, and sometimes the f1, othertimes the f3 has the gdm and everything works smoothly

Thanks for the help

I am also having this issue - any fixes/clear instructions on how to resolve this?

Edit: After looking at the stable update post - removing “splash” from GRUB boot fixed it.

4 Likes