After package update: sddm-greeter dumps core


#1

Hi :slight_smile:

I updated my Manjaro-Arm packages today (last update was done about 5 days ago) and now when the system boots up instead of the graphical login screen I get a black screen. The boot process works fine and the system is up, only the graphical login fails to start.

journaltcl --since=today reveals the cause:

ssdm-greeter[719]: Cannot mix incompatible Qt library (version 0x50c00) with this library (version 0x50c01)

systemd-coredump[726]: Process 719 (sddm-greeter) of user 994 dumped core

Since I have no graphical desktop I tried to see if I missed a package update by running: pacman -Syu but it it says: “there is nothing to do” So my system is up to date, but this update seems to have caused a mix of incompatible libraries to be installed.


#2

Same thing happened with Manjaro32, sddm probably needs a rebuild against updated Qt packages.


#3

Could be. But I noticed that lots of qt5 packages did not get updated in our repo when qt5-base did.
Like qt5-declerative did not get updated. Which sddm depends on.
So i just tried pushing that update first, to see if that fixes it.


#4

Just updated the rest of the qt5 packages in the repo.
Please do another update, when our mirror has synced. :slight_smile:


#5

I just did: pacman -Syu and it fixed the problem. Thank you guys :slight_smile: