After Last Testing Update - Failed to start load kernel modules? (Kernel 5.18.12-2)


Running Manjaro KDE fully updated on the Testing branch.

After last Testing update I get the following error when booting computer:
“Failed to start load kernel modules” ?
(running Kernel version 5.18.12-2)

How do I fix this?


Redownload the kernel again …


I tried that, but when reinstalling the Kernel after reboot I get error:

The following packages will be installed:





resolving dependencies...

looking for conflicting packages...

Packages (3) linux518-5.18.12-2 linux518-nvidia-515.57-7 linux518-virtualbox-host-modules-6.1.34-16

Total Installed Size: 171.89 MiB

:: Proceed with installation? [Y/n]

checking keyring...

checking package integrity...

:: File /var/cache/pacman/pkg/linux518-5.18.12-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

Do you want to delete it? [Y/n]

Errors occurred, no packages were upgraded.

error: linux518: signature from "Manjaro Build Server <>" is invalid

error: failed to commit transaction (invalid or corrupted package)

Done ...

Ok, I tried again and it worked.
Now no error message when booting computer.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.