After installing to HD from LiveDVD (vs 18.1.0) I cannot log in!

After taking manjaro live for a spin, and very much liking what I saw, I decided to install it to HD (SSD, actually) in its own ext4 partition on an MBR disk that it would share with Win7. Should be pretty straight forward. BUT -
Upon completing install and rebooting, it came up challenging me for username/password, as one might expect. The first sign of trouble was that it was presenting my personal name as username INSTEAD of the username I had specified at install. So I proceeded, giving my password that I had chosen for the username I had specified. No go.
So I tried "another account" so I could enter the correct username, and then the password. No go. So then I tried "root" and the same password, for that is also what I specified upon install when asked if I wanted to apply the same p/w for "the admin account," which I assumed to mean "root." Again, no go.
So I tried the originals (manjaro/manjaro and root/manjaro) but, not surprisingly, those both failed, too.
Apparently, I can't get there from here (one of my favorite sayings).
Oh - come to think of it - post-install bootup showed NOTHING like a grub menu to offer my two choices. Of course this means I can't get to Win7, either.
Clearly, the thrill is gone, as the song goes. I'm now facing a whole LOT of work just to get Windoze back, if nothing else.
Any clues or silver linings?

  • What keyboard layout did you use while typing your password during install?
  • Does your password have any special characters?
  • Did you do a pure legacy BIOS install?
  • What flavour of Manjaro do you use?
  • Did you change your 'real name' each time to your 'user name'?

Nothing more simple than that on a legacy/MBR dual boot system: Start a Windows recovery medium, open a command prompt window and enter:

bootrec.exe /fixmbr

Afterwards, Windows boots as Manjaro has never been installed.

Thanks for that reminder. By the time I found your RE, thouigh, I'd already restored the MBR with a simple dd copy of the 1st 446 bytes. Then I did a reinstall of manjaro, this time vs 20. Dual booting fine now, but (on an entirely different topic, granted) I'm having non-fun trying to figure out how/why rfkill is shutting down my WiFi so I don't have to manually unblock it every time I boot up. Gotta be easy, but I find ZERO on rfkill here in nube city???
Thanks again, anyhoo!

us eng kbd
no - nothing but upper & lower letters
yes - just MBR
flavor? meaning which desktop? 18.1.0 w/ xfce
tried everything, as I stated: full name, user name I'd chosen, root AND "manjaro"

Trashed it and reinstalled vs 20, eventually getting password I stipulated (after MULTIPLE runs of passwd!)

Forum kindly sponsored by