After installing NVIDIA Packages, I was unable to modify the frame rate/refresh rate. Missing panels

As the title states, I believe that there are missing panels in NVIDIA X Server Settings. I tried running Minecraft but my fps was stuck at 60. I tried changing it through the game but it didnt work so I assumed that it was my drivers’ fault. Before that, let’s take a step back and see what I did so far. After getting drivers installed (post: I was able to run games. However I couldn’t run them to their full potential. I tried modifying it through nvidia-settings but there wasnt a panel dedicated to display settings or something like that. So I’m kinda lost.

Are you running the game via your nvidia or just running it normally?

Just opened the game without doing anything right after insalling them. Am I supposed to modify something?

Yes, run your game via this line:
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia [name of the app i.e minecraft]

If the above doesn’t work, go to a terminal and try:

cd /path/to/minecraft

where /path/to is the directory you installed minecraft in and then execute:

DRI_PRIME=1 java -jar launcher.jar

and your FPS should shoot through the roof.


sooo i kinda listened to a friend of mine and did this sudo mhwd -i pci video-nvidia-450xx as instructed in a guide. Now my Linux wont boot up again. Do I have to go through the entire process again as i did in

or is there a quick fix to it. I couldn’t uninstall the driver i installed either.