After installation with "erase" option, no boot device is found

Here’s what I did so far:

  • Booted USB with Manjaro 22.
  • Chose “Erase” option with “Hibernation” (success)
  • restart

No bootable device found. It’s a Dell Latitude laptop (2019)

I started tinkering around with BIOS settings, but so far no luck. When I try to edit the boot sequence, there’s just no disk (unless the Manjaro USB is inserted.)

This laptop has a Toshiba SSD. If you think I should list more of my BIOS settings here, let me know.

  • I don’t have “fast boot” as an option
  • Network boot disabled.
  • “Secure boot” disabled.
  • “Legacy mode” disabled, doesn’t seem to make a difference.

I hope this is the right category.

You erased the disc so there won’t be any bootable disc.

Can you boot the USB again, run fdisk -l, and paste the outputs?

It’s an option in the installer to erase rather than re-partition. I can mount the internal drive when I boot from the USB, so i see that the installation worked.

Yikes, well I’m on another computer here. I see /dev/sda1 (EFI FAT-12…)

/dev/sda2 (swap) and /dev/sdb (the flash drive)

/sdb1 (empty) and sdb2 (EFI)

I will try to login from the laptop if you think it’s necessary.

That makes me think that your UEFI needs an explicitly flagged partition to boot. Commonly, it is the EFI partition on an UEFI system. Some UEFI’s need it flagged with boot, or esp or boot, esp, some don’t and dynamically discover it on boot time.


Or there was a problem when creating an entry in the UEFI Bootloader which wasn’t reported. You know the UEFI Bootloader loads the file in the efi partition which then loads the Grub Bootloader etc.

I’ll check again, but I believe it’s flagged with “boot” and “esp” already. I had to add the esp flag, but didn’t change anything.

Are you sure those are the only partitions it found? Cause it’s saying that you don’t have a partition for your root, which should have been created by the installer. If the only partition on /dev/sda is your swap, then that would be strange.

1 Like

OK, you didn’t say you installed after the erase. You should be able to boot the usb stick and with the partioning app mork the drive bootable. Maybe

Under disk -l …

/dev/sda1 (* boot) 229G EFI (FAT 12-/16/32)
/dev/sda2 (no star) 8.8G Linux swap / Solaris

Just the two partitions.

The drive is marked bootable but you have no /root partition. no OS

1 Like

Well, where is the root partition? You cannot use the EFI Partition as root directory. I cannot believe that this is the result of an erase…

1 Like

I would say just try the installation process again. You might have accidentally clicked something in the installer that messed things up.

I’ll try “Erase disk” again

This time around it’s showing me something different:



That is the desired end result.

Not sure. Before it had 4 partitions (Windows junk) and it gave me an option to install to the “Toshiba” or to “root” and I chose Toshiba LOL.

Maybe I should have chosen “root” but I’ll never know. 3rd time around, I didn’t have that same choice.

Rebooting now.

Wow it worked! Woohoo.

FWIW that was the 3rd time reinstalling with “Erase.” Unfortunately, I don’t know what the exact solution was. Three times is a charm? LOL.

1 Like

Is it possible I had the wrong BIOS settings which prevented the installer from creating that entry in the UEFI bootloader?

When I was distro hopping, so many of my problems were resolved by “reinstall and do it again”. It’s like the “have you tried turning it off and on again?” of installing operating systems. Who’s to say what happened? Computers can be very weird sometimes.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.