After installation Windows 11 boots instead

I don’t understand your konsole issue. Can you not type in su enter then type in the root password to get to a root prompt?
As a side note; if you are at all unsure of what you are doing, don’t go mucking around as root. Especially dealing with grub or any system required files. You can render your machine useless real fast.

I dont understand it either. No I cant become root not even using sudo,I cant even update this installation. When I go to updates it lists 900 updates but every time I try to install one or all of them it says “invalid or corrupt package”

Yeah I did save the original file as a backup like I typed in above, I guess you missed that part. No I did not save the file I changed as a backup. It just does not work on this setup. . I am going to download it all new. I bought this online from a vendor on Amazon on a pen drive and I feel it may have a virus or malware even though I virus scanned it before I tried to dual boot. BTW I have been using Linux since 1995 in different versions so its not like I am totally new at this.

Like I wrote above I am using Windows 11.

I can become root in Konsole, what I meant to write is that it still wont let me do anything as root. Even kate after trying to save the file I changed asked for password to save as priveledged user but still would not save the file. sorry for the wrong reply but this has me vexed.

I tried this again and this time I seen where my grub file has updated! I came up with this and i am going to reboot and see if it works this time.
[sudo] password for ed:
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings …
Found memtest86+ image: /boot/memtest86+/memtest.bin

No, it still boots straight into Windows 11 . I can only get here (manjaro) by holding F3 to get into bios. This is disheartening to say the least. I guess the system is corrupt. I seen in another thread about updating mirrors to stop message “invalid or corrupt package” that I receive when trying to install either 1 or the entire 900 updates my system needs, it did not go too well either. if interested read here - Invalid or corrupt updates
Would you have any idea the best way to totally remove this install without affecting my dual boot windows 11? I am afraid there is some kind of virus in the Manjaro install as nothing seems to work like it should.

no there is no virus …
did you disabled secure boot in bios
did you disabled fast boot in bios - you may not have this option
ahci needs to be enabled
did you disabled fast startup in windows

I disabled secure boot in bios, there really is no other way to even install without doing that. I set up UEFI boot also.The ahci is already enabled as it is in most modern computers, and no I have never ENABLED fast startup so there is no need for me to disable it. I also had to disable BitLocker to even get it to install. Please dont tell me that you are one of those few people that think just because Linux has a small share of, less than 3% of the worlds PC operating systems that there are no viruses in Linux? lol

Have you tried this bit? [root tip] [How To] Dual boot Manjaro and Windows

Uhh, thanks again for that tip. I am using Windows 11 as I posted here in response to the last person that offered me this. This is a tip for booting from Windows 10.

Aw, I missed that, sorry (long thread). Windows 11 is demanding and may require secure boot which manjaro doesn’t support yet out of box.

The beforementioned bcdedit /set works on Windows 11, too. However, before setting BCDEdit options you might need to disable or suspend BitLocker and Secure Boot on your computer.

I don’t see anyone suggesting the most obvious. Did you go into your BIOS, and set manjaro as the first boot option? If you can manually boot to Manjaro from BIOS, you can surely set it as first boot option.

No, is that needed? I set my Bios up with USB as first boot option to get the USB drive with Manjaro on it to boot. I will have to reboot and enter Bios and see if that is an option, I wonder if that will allow me to boot windows or if given the choice will it boot either?

I already had to disable Bit locker and secure boot as well so that was taken care of.

I checked my bios and there is no option for Manjaro Boot in Biois. That makes me think my system did not properly setup boot loader, which after all the 927 updates installed seems really odd. This is my Bios boot options.

I will likely erase this disk and start again with another OS as Manjaro does not seem at all user friendly or capable of running on a new machine. Even with proprietary Nvidia drivers loaded I get a random screen blackout for a few seconds and when mousing near edges of screen I occasionally get garbled graphics. Its a shame after all the many fixes I have tried. smh

UEFI HARD DISK DRIVE BBS PRIORITIES → get in there and put Manjaro first.

no comment…



For future readers (as the OP seems to have gone elsewhere): The screenshot shows “UEFI Hard Drive BBS Priorities”. When clicked open, probably the disk where GRUB / Manjaro is located can be selected as the first one to boot. (That is how it works on my ASUS motherboard). [oops, sort of double post]

Yes that’s what I said one post earlier.