After Installation: "Start PXE over IPv4" / Cannot mount EFI for grub-install

I have installed Manjaro 21.1.0 off the latest minimal ISO. Chose to erase the hard drive and install into a new BTRFS partition with encryption. No issues during installation, but after restarting the computer, I get the message “Start PXE over IPv4”.

I have reviewed the boot order, which seemed fine. Removed the Manjaro boot option since it’s not working anyway. Checked the NVME in the BIOS, it’s all good.

Booted into the live system to reinstall and reconfigure GRUB. Mounted the encrypted LUKS partition. Now I have two relevant partitions:

  1. /dev/nvme0n1p1: EFI partition
  2. /dev/mapper/luks-abcdef: Root partition

Following the instructions from another thread in this forum, I did the following:

# mount /dev/mapper/luks-abcdef /mnt
# mount /dev/nvme0n1p1 /mnt/@/boot/efi

If go to /mnt/@/boot/efi, I can see the EFI dir inside, so this seems to have worked.

Unfortunately, if I chroot like this:

# manjaro-chroot /mnt/@  /bin/bash

…and go to /boot/efi, the directory is empty.

If I try to do a grub-install, I get this unsurprising error:

# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
Installing for x86_64-efi platform.
grub-install: error: /boot/efi doesn't look like an EFI partition

This isn’t the first time that I have to fix GRUB, but the first time using BTRFS and the first time that it isn’t working. Can anyone see what I’m doing wrong?

Maybe this makes it clearer:

#mount root subvolume
mount -o subvol=@ /dev/mapper/luks-abcdef /mnt
# mount home subvolume
mount -o subvol=@home /dev/mapper/luks-abcdef /mnt/home
# mount efi partition
mount /dev/nvme0n1p1 /mnt/boot/efi 
# chroot
manjaro-chroot /mnt /bin/bash
1 Like

Thank you! This worked perfectly. grub-install executes without error and the boot option gets created at 0000.

Unfortunately, the system can still not boot from this boot option. I‘ll try reinstalling the OS and if it still won‘t work I‘ll try installing it on another NVME tomorrow. Perhaps the NVME is toast.

ETA: Reinstalled Manjaro with the same settings and now it’s working.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.