After-installation issues: booting is hit and miss

boot

#1

I just installed the latest Manjaro KDE image (17.0.6 Gellivara) to a brand new machine. It installed fine and booted after the install. On first run, I updated the system using Octopi.
After that, I had an unsuccessful reboot with the boot messages you can see attached on the photos.
The next reboot was successful though and I tried again to be sure, which worked. I proceeded with system setup and it failed again: this time, slightly fewer boot messages. Now the last 5 consecutive reboot attempts were unsuccessful, but differing boot messages again, see all attached.

(this was actually the second attempt - the first one was with free drivers setting - and when I encounterd this problem first, also only after updating, did a reinstall, this time with non-free drivers. However, my system has an Intel chipset and I doubt it is a drivers issue. So these photos and problems described are from the second installation)

The “namespace lookup failure” is always there, and the PCIe error is only missing on the last one. I thought it was gonna proceed booting there, but it was stuck.

Let me mention again the system rebooted fine after the install. It was after the first update that I ran into problems (on both installations).


#2

Both errors you have are not critical. The real problem you are dealing with is most likely sddm v0.16 issue. Switch to another tty (Ctrl+Alt+F2) and follow the instructions below:

If you are annoyed by ACPI messages, try upgrading your mobo firmware.
That other issue is described here: https://askubuntu.com/questions/771899/pcie-bus-error-severity-corrected


#3

Thanks for the quick reply. In fact none of the problems I found on the internet related to these errors was serious trouble like failure to boot.

I tried to follow these instructions but I’m afraid I don’t understand them very well.

  1. I can get into tty2 but it gets flooded with these error messages.

  2. Typing is a huge drag because the key map is apparently qwerty while my actual keyboard is qwertz

  3. In don’t understand what "Edit unit: systemctl edit sddm"
    and “Add to the editor (10s delay):” means.
    Which file am I supposed to edit?

I tried running systemctl edit sddm which gives me an empty file.
If I write:

[Service]

ExecStartPre=/bin/sleep 10

in that file, it’ll be automatically saved as /etc/systemd/system/sddm.service.d/override.conf and delay the start of SDDM (whatever SDDM may be), is that it?


#4

Correct. This is for permanent effect. That should work after next reboot.

You can also simply try:
systemctl restart sddm
to get into KDE and do everything in GUI rather than CLI. And that will also prove that sddm is the issue.


#5

Man, sometimes correct/accurate English (by that guy who posted the instructions) would really be so helpful…

I’ sorry to say, that didn’t work. :disappointed_relieved:

The file that is automatically created by running systemctl edit sddm actually has a weird filename with a long string of apparently random chars attached to override.conf

I tried both using that as well as just override.conf, both to no avail. I also edited it from a live environment using my installation flash drive when that weird filename made me nervous.

Also,
systemctl restart sddm
leads to this: https://youtu.be/DhSCmeNkZYc

just the error messages flickering over the screen - and I can’t do anything anymore at that point, further input from keyboard is not accepted.


#6

That’s unfortunate.
I saw you loaded 4.14.3 kernel. Can you try booting from 4.9 one? You should have it installed.

Also some info would also help: The output of
inxi -Fxzc0
and
journalctl -b -p err


#7

To change the kernel that boots I would first need to boot successfully, no? I had a couple of successful boots scattered inbetween ~4 times the number of unsuccessful ones, which was where I installed 4.14. The last ~10 attempts were unsuccessful though.

I obtained inxi information in a live session (that’s why it says kernel 4.9 there):

[manjaro@manjaro ~]$ inxi -Fxzc0
Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System:    Host: manjaro Kernel: 4.9.58-1-MANJARO x86_64
           bits: 64 gcc: 7.2.0
           Desktop: KDE Plasma 5.11.2 (Qt 5.9.2) Distro: Manjaro Linux
Machine:   Device: laptop Mobo: ZOTAC model: ZBOX-CI527/CI547 v: XX serial: N/A
           UEFI: American Megatrends v: B331P206 date: 04/25/2017
CPU:       Dual core Intel Core i5-7200U (-HT-MCP-)
           arch: Kaby Lake rev.9 cache: 3072 KB
           
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10852
           clock speeds: max: 3100 MHz 1: 735 MHz 2: 1092 MHz 3: 485 MHz
           4: 481 MHz
Graphics:  Card: Intel HD Graphics 620 bus-ID: 00:02.0
           Display Server: N/A drivers: intel (unloaded: modesetting)
           tty size: 77x24
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.9.58-1-MANJARO
Network:   Card-1: Intel Ethernet Connection I219-LM
           driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full
           mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 01:00.0
           IF: enp1s0 state: down mac: <filter>
           Card-3: Intel Wireless 3165 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 536.9GB (1.7% used)
           ID-1: /dev/sda model: Crucial_CT525MX3 size: 525.1GB
           ID-2: USB /dev/sdb model: USB_2.0_FD size: 4.0GB
           ID-3: USB /dev/sdd model: DataTraveler_3.0 size: 7.8GB
Partition: ID-1: / size: 5.8G used: 98M (2%) fs: overlay dev: N/A
           ID-2: swap-1 size: 9.45GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 54.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 190 Uptime: 3 min Memory: 1098.9/7903.5MB
           Init: systemd Gcc sys: 7.2.0
           Client: Shell (bash 4.4.121) inxi: 2.3.40

Would journalctl also be helpful from a live session?


#8

No. As long as you get the GRUB Screen you can choose what kernel to boot.
Kernel 4.9 is installed by default on Manjaro 17.
So you should be able to get to Grub, choose Advanced Options and choose the 4.9 kernel option in there.


#9

Alright, I did that. Can’t say it was a better experience. :neutral_face:
After adding the 10s delay in override.conf again, two new lines have added themselves to the boot msgs:

[  OK  ] started SDDM
[  OK  ] reached target graphical interface

…which is an outright lie, it’s still stuck right there.

systemctl restart sddm also produced the flickering + inability to get back to tty1.

I’m trying to figure out how I might get the output of journalctl -b -p err saved onto a flash drive. It’s a total nightmare using the terminal with the wrong keymap, and the error messages flooding in between. I type the beginning of a command, then come 10 lines of error messages and I can find the end of my command attached to the bottom of that, if I’m lucky.
Or isn’t there any way to retrieve that journal from the harddrive in a live system too? I wouldn’t know where to look though.

UPDATE: Understanding this after having solved the problem: This fix was necessary for SSDM, but the graphical interface still wouldn’t start because I was also using the wrong graphics driver (xf86-video-intel). I only went away after swittching to the modesetting driver.


#10

My guess is now graphics drivers.

Can you give me the output of mhwd -li from anothet TTY?


#11

Which kernel?


#12

Doesn’t matter if no one of them boots. :slight_smile:


#13

right now, the free driver should be in use. I started out with the non-free one though, and the problems occurred before I switched to the free one.


#14

mhwd -li


#15

Do you use a wireless keyboard/mouse?
Lots of those errors mention something about a reciever ID.

Drivers should be installed, if you only have an intel card in your system.


#16

Yes, Logitech K260 wireless mouse/keyboard combo. This would be the first time in years of use with Linux I’d have any problems with this set (except once with a RaspberryPi 1 rev.B).
However, maybe that can be solved with the info on that askubuntu link that romca posted - but I’ll get to that once I manage to boot reliably, since this doesn’t seem to be the problem.


#17

journalctl -p -b err

This doesn’t seem new, does it? Just the ntpd messages, which I don’t understand what they mean.


#18

Did you try internet searching your actual error messages?

PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5

I believe this may be due to PCIe Active State Power Management that is transitioning the link to a lower power state and maybe causing the device to trigger these errors.

Try using the pcie_aspm=off boot parameter to see if this stops the messages. Note that this will increase the power consumption of your machine as it disables the power savings.


#19

Yes, I did. But like romca said earlier and others said in postings I found, these errors aren’t critical in that they shouldn’t actually prevent my session from starting. I might get rid of them but still be unable to complete startup.


#20

I tried these boot parameters separately with kernel 4.14 now:

pci=nomsi
pci=noaer
pcie_aspm=off

All of them, separately, get rid of the PCIe error. None of them gets rid of the problem, still won’t complete startup.

I also tried pcie=nomsi and pcie=noaer just to be sure, but those seem to be bogus parameters, they changed nothing.