After initial upgrade system hangs after grub with black screen

xfce
i686

#1

I’ve tried both the manjaro32 17.1.1 rc2 and the 17.1.7 rc1 xfce installers and worked past several issues however I think a newer version is needed because the entire system hangs after downloading 1gb in updates and rebooting. I’m testing in a virtualbox 32 bit vm. so the environment should be “standard”. I restored to a pre-upgrade snapshot and tried the upgrade again after deselecting the linux 414 kernel, headers etc to see if that helped. No change. Perhaps a new installer that already has all the packages would resolve the issue at least for now.

Suggestions? Otherwise, I’ll revisit when the next installer candidate comes out.


#2

Here is the link to the latest builds for the 32 Bit https://osdn.net/projects/manjaro32/

It is better to switch to 64 bit as the 32 repos are all community maintained and progress will not be at the same speed.

Are you trying to run on old hardware?


#3

As I mentioned, one of the installers I tested was 17.1.7 RC1 which is the latest you are pointing to.

For testing purposes I’m running it in a virtualbox 32 bit session so the hardware would be “standard”. Eventually the intent is to upgrade some older laptops so “upgrading to 64 bit” isn’t an option for these specific purposes. I already have multiple machines running the 64 bit KDE version.

I understand manjaro32 is community maintained. It’s why I added the i686 tag to the post so hopefully the people involved can see the issues encountered.

I’d provide logs but it’s not at a point in the bootup process where that is possible.


#4

specifically,


#5

Thank you so much Jonathan. I’ll try to do better searching as I did browse the forum for boot issues but didn’t think to add virtualbox to the search terms. Now I can continue prepping to upgrade my ancient laptops. I prefer to use them when travelling because if they get stolen I haven’t lost much.

Well I enabled the virtualbox setting and I edited the command line on bootup to add nomodeset followed by F10 to boot and it appeared to get farther however it showed starting the TLP service and that’s as far as it got. I’ve restored a “pre updates” snapshot and added the nomodeset directly to the /etc/default/grub followed by update-grub but I don’t see TLP being mentioned. I could be missing things again though. I’ll see how it behaves after the updates apply again.

I’ve moved to the “can’t start light display manager” stage…after research it tells me to hit ctrl alt f2, login and run systemctl enable lightdm.service, systemctl start lightdm.service.

The problem with that is ctrl alt f2 sends me to the HOST command line and not the vm’s. I’ll do more research when I have time but it’s 4:22am and I’m tired/frustrated with it at the moment so best to take a break.