After December 31 Update Deepin Dock not showing

#1

After update the DDE dock didnt work so I restarted now all I get is a blank desktop. I tried restartdde and get an error:
manager.go:89 Launch ‘dde-dock’ failed org.freedesktop.DBus.Error.Spawn.ChildExited:Process com.deepin.dde.Dock exited with status 127

I also ran sudo pacman -Syu it updated Deepin packages but than got an error failed to commit transaction (conflicting files)
manjaro-deepin-settings: /etc/skel/.config/deepin-wm-switcher/config.json exists in filesystem

Still no dock

0 Likes

[Stable Update] 2018-12-31 - Kernels, KDE Apps, KDE Frameworks, VirtualBox, LibreOffice, Deepin, ZFS
#2

I had same “conflicting files” message. Problem is that the file doesn’t belong to any package.
I updated my system with:
sudo pacman -Syu --overwrite /etc/skel/.config/deepin-wm-switcher/config.json

0 Likes

#3

i got the same error during my update and this fixed it
i pulled this from the stable post

0 Likes

#4

Thanks for the replies. I changed to the original china Deepin. Maybe I will revisit the Manjaro Deepin in the future

0 Likes

#5

I’ve fixed the file conflict with a new package update of manjaro-deepin-settings - the problems with the dock I cannot reproduce atm, but also I have some other issues currently with the 18.0 ISO image I am still working on. I hope to be able to fix it soon.
Thing is that basically we only use upstream packages from Linuxdeepin and Archlinux with very little customization at the moment. So most likely there are just still some issues with the latest Deepin package releases …

1 Like

#6

Greetings and thank you very much for delivering the Manjaro Deepin Edition. Also Happy New Year!!

I’m currently on Manjaro Deepin, my last update was from 12-23 on the stable channel. Should I go ahead and update Deepin or would it be more advisable to sit back and wait until things hopefully get worked out? My current setup runs just fine. I do like having constant updates, but I do enjoy stability just a little bit more heh heh.

0 Likes

#7

I’m afraid I cannot reproduce the dock issue on my system…
Currently building ISOs with latest stable packages. Everything working as it should:

3 Likes

Not able to boot into graphical session after 2018-12-31 update
#8

I am on “testing” and all is fine.
I allways make backup’s with “Timeshift”.

Make a backup and go into battle :wink:

0 Likes

closed #9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

0 Likes