After customizing panel, Manjaro won't boot any more


#6

Any chance you were running an update during all this? These issues sound like what a number of people are reporting currently because of failed updates.


#7

Actually I did see that I had some updates and clicked to view them right before I was doing all this modifying. I think I just x’d out of the update window without actually starting to install them though. But if I had actually clicked to install and then someone cancelled it… that might cause this?


#8

Yes, I think so. Most major problems people have reported are when the latest update was interrupted for some reason.


#9

Wow, okay. So since I haven’t been able to get to a terminal, is there any other way to try to reinstall the updates? Or am I gonna have to just start with a fresh install?


#10

I would try booting live iso, chrooting to your installation with

  manjaro-chroot -a

Then update the system with

  pacman -Syu

Fix any problems with the update until it succeeds.

Then run

   mkinitcpio -P 
   update-grub 

Then reboot to your normal system.

If that doesn’t work, rollback in the chroot the update that caused the issue and retry.


Can't boot Deepin after update
Black screen after failed update kde
#11

edit: follow @Chrysostomus steps, they are a little simpler than the guide I linked to

When logging to tty fail (some got in after trying 15-20 times and trying F3 or F4…) then next step is to use Live Manjaro media and boot from it and chroot into your system (chroot = change root)

Then once you are chrooted into your broken system, you can run system update from there.


#12

So once I boot to live USB will I need to mount the file system as in the guide that AlManja posted or can I directly run the “manjaro-chroot -a” command?


#13

I edit my post advising to just follow @Chrysostomus steps since they are simpler. Guide is based on older tool and there are few extra steps involved.

As far as I understand:

manjaro-chroot -a

automates mounting & chrooting for you as long as you are not using btrfs file system - if you are not sure, then you don’t use it… (but I have yet to try this automated way myself) :slight_smile:


#14

Ah sorry, I missed that edit. Thanks for clarifying. I’m at work now but I’ll try this out later tonight when I get home.


#15

Good luck and I hope it works for you!

Chrooting is very powerful tool, and with it you should practically be able to always get back in if system is not too damaged. Well depends of someone knowledge. But definitely keep this ‘chrooting’ in your tool box :slight_smile:


#16

Thanks! Will do!


#17

If you can get here, just select option #1, but there will also be a command line area where you can enter other text.
Just enter a 3 (a single digit 3) at the end of that line, and it will boot to a terminal without trying to load your graphical environment. You will see a login prompt.

If that works there’s no reason to do the chroot step at all.

You will have to then finish the update that apparently got half started, with pacman commands.
pacman -Sy manjaro-keyring
pacman -S manjaro-system
pacman -S lib32-mesa
pacman -Syu mhwd

Another Alternative: Since you were just doing preliminary configurations on a new install, and have essentially nothing invested in this install, you might want to download 17.0.1 which is newer and includes all the troublesome patches and re-install:

https://manjaro.org/get-manjaro/


#18

Ok guys… I tried @Chrysostomus 's solution initially and it kept asking me which installation to mount but it wouldn’t let me mount it. After that I tried going through the guide posted by @AlManja and after mounting it myself I was able to chroot into my old installation! I just did a quick ls check to make sure I was in the right place and I was able to see my files and whatnot.

So then I tried using sudo pacman -Syu and it said core, extra, community and multilib was up to date. Then asked me to replace manjaro documentation. I said yes. Then asked me to replace pacman mirror list, I said yes. Then listed about 65 packages to install. I said Yes to proceed with installation. I now am getting the following error:

error: could not open file: /etc/mtab: No such file or directory
error: could not determine filesystem mount points
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

And that’s where I’m stuck at now…


#19

I’m sorry to hear this. Beginner myself I have nothing else to offer. Hopefully someone else may have some idea soon what to do next


#20

Here is original post about chrooting, maybe try this?

https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader#Chroot_into_your_existing_Manjaro_Installation


#21

Searching Manjaro forum for instances where someone else had same or similar problem I found this:

You haven’t done it properly. Start over. Either use sudo mhwd-chroot as explained in the section Use mhwd-chroot or follow the tutorial entitled Manually Identify and Prepare the Installed Partition(s) - stop at the end of this section.

Then update the entire system: pacman -Syu

Finally, exit the chroot environment and reboot.


#22

Looks like using mhwd-chroot got past that error! Had to install yaourt first to get it but it seems to be proceeding with the install now.


#23

That did it! After using mhwd-chroot (thanks to @AlManja) I then was able to finish following @Chrysostomus solution and upon restarting everything is working fine now! Appreciate the help from everyone! @cimarronline, @AlManja, @jsamyth, @Chrysostomus


#24

I’m glad it worked for you! :slight_smile:


Can not enter my desktop after cancelin update
#25

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.