After Advice on Performance

Afternoon all.

Messing around with Manjaro again lately. Still hoping to fully switch from Windows.
My main goal is to get performance somewhat on par to that which I get in Windows, primarily for UE4 dev.

I currently have Manjaro KDE stable installed, and while the desktop performance seems pretty solid, I don't seem to get very good stability in UE4 or in games.

Afaik I am running a pretty vanilla setup. Only really changed themes.
INtel Core i7-6700k
GeForce GTX 1070
32GB Ram
SSD drives
2x 27" 2560x1440 monitors

I guess all I want to ask is, should I attempt to fix KDE's performance or try another DE?

Cheers all. Sorry for the dumb questions all the time.

Could you be more specific on exactly what performance issues you are seeing?

Sure.

So recently my tests have been with Borderlands 2 and Unreal Engine 4.

Borderlands 2 has severe stutter, FPS seems to stay pretty constant at 60FPS according to the steam overlay. But it sceentears and jitters about quite severely. Also, mouse speed is pretty much uncontrollable. Way too sensitive making it move too quickly. But this is only in this game. Desktop mouse speed is fine.

UE4 seems to run ok, again, solid 60FPS at all times. However, when the editor itself is open, the DE is very laggy. Cursor stutters when moving from screen to screen and over UI elements, both in Unreal Editor and in the DE itself (File Manager, application menu.)

Try reading through this post and see if any of the steps outlined there resolve your issue.

Screentearing isnt an issue. I was able to resolve that in KDE. It was only tearing in Borderlands.
Upon testing just now. Borderlands seems to be running absolutely fine.

The main issue is with Unreal Engine.
I have a blank project open currently, if I click on the file menu top left and move the cursor up and down the menu entries, it is very laggy. Infact, moving the cursor around any UI elements is very laggy in UE.

It feels like everything is missing a few frames when moving. Now, if this was just a menu issue only I could deal with it, but trying to do any shader work in the material editor is a nightmare as everything feels sluggish.

EDIT: The Arch Wiki suggests disabling tooltips.
https://wiki.archlinux.org/index.php/Unreal_Engine_4#Slow_rendered_tooltips_in_KDE

disable compositing before running the game/ue4.

forcefullcompositionpipeline will kill performsnce

You have gotten plenty suggestions.

I would say go WM - Openbox is highly recommended :slight_smile:

https://wiki.unrealengine.com/Linux_Known_Issues#KDE
Says here to make sure KDE's composition is on for UE4.
On or off doesn't improve it.

Force CompositionPipeline and ForceFullCompositionPipeline are both disabled in the nvidia X Server settings.

I'd rather not switch WM/DE, but if i did. Openbox probably wouldn't be my first choice.

All I have done to fix the screen tearring issue is add "export KWIN_TRIPLE_BUFFER=1" to /etc/profile.d/kwin.sh

However, that file is blank other than that line, so I am doubtful of that doing anything useful.

i think this is a much better option than FFCP or FCP for tearing, so you did the right thing there IMO.

it's where i went after growing tired of the never ending bug loop that is KDE and loved it. after openbox i tried i3 and i felt like i needed to grow more fingers to use it and finally to Awesome-wm which is a perfect fit for me.

the more important part is probably nvidia configuration and/or messing with Kwin. using xrender is what i found to work the best when i used kde but who knows now. xfce works great after installing compton and disabling xfwm's built in compositor if your not into the WM thing.

post output of:

mhwd -li
cat /etc/X11/xorg.conf.d/*.conf

OK. So I just removed that file "kwin.sh"
Restarted.
Double checked sync to VBlank is off.
Both Composition Pipelines are off.
Then in KDE's compositor settings, I set "Allow programs to block compositing" to false.

This has stopped the screen tearing in Firefox, Dolphin and whatever else. But UE4 is still very sluggish.

also inxi -Fxxxz

mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2018.08.09               false            PCI


Warning: No installed USB configs!
cat /etc/X11/xorg.conf.d/*.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "gb"
        Option "XkbModel" "pc105"
EndSection
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 418.43

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
        Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
inxi -Fxxxz
System:    Host: Gloin Kernel: 4.19.49-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5 
           tk: Qt 5.12.3 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 3202 
           date: 02/07/2017 
CPU:       Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP arch: Skylake-S rev: 3 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 64152 
           Speed: 800 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: eVga.com. driver: nvidia v: 430.14 bus ID: 01:00.0 
           chip ID: 10de:1b81 
           Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: kwin_x11 resolution: 2560x1440~60Hz, 2560x1440~60Hz 
           OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 430.14 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a170 
           Device-2: NVIDIA GP104 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f0 
           Device-3: SteelSeries ApS type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-4:2 chip ID: 1038:12ad 
           Sound Server: ALSA v: k4.19.49-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           chip ID: 8086:15b8 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 372.13 GiB used: 99.93 GiB (26.9%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 950 PRO 256GB size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 1B0QBXX7 scheme: GPT 
           ID-2: /dev/sda vendor: SK Hynix model: HFS128G32MNB-2202A size: 119.24 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: BL00 scheme: GPT 
           ID-3: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 size: 14.41 GiB serial: <filter> scheme: MBR 
Partition: ID-1: / size: 116.58 GiB used: 99.93 GiB (85.7%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 50 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
Info:      Processes: 215 Uptime: 3h 29m Memory: 31.36 GiB used: 2.88 GiB (9.2%) Init: systemd v: 242 Compilers: gcc: 8.3.0 
           Shell: bash v: 5.0.7 running in: konsole inxi: 3.0.34 

Well - you asked for opinion :laughing:

I do a lot of coding - and neither Gnome nor KDE was stable enough - I mean - I don't want to spend time fixing the DE - I just want my system to work.

Openbox fit's that bill - rock solid.

Maybe use kde for most system use and openbox only for ue4?
Well I guess that's more of a workaround, not really a fix.

1 Like

that all looks fine. since it's recommended to keep the compositor enabled according to the link you posted you can try alternative options for compositing. try xrandr, then the others along with the other related compositor options kwin has.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.