After 5.8 update (on 8/29/2020), login fails

After I updated my system (many packages updated), when I type my password in the login screen, it pauses for a few seconds, clears the password box, and nothing happens. I tried this using a different user, and the same thing happens. I also tried at the command line (ctrl+alt+F2), there it says “Login incorrect”.

I followed some info in the stable release announcement about managing my pacnew and pacsave files, but there was no change, after rebooting.

I am running 5.8 with KDE/Plasma.

Any help is greatly appreciated!

How did you did that? Can you login with some user? Did you chroot from a installation media?

Have you check journalctl?

Thanks for the reply.

Yes, I booted with a USB installer (Manjaro 19), did a chroot then went through pamdiff.

I checked journalctl and found some errors.

Aug 31 12:44:36 ZergBuster login[1321]: PAM unable to dlopen(/usr/lib/security/ /usr/lib/security/ cannot open shared object fil>
Aug 31 12:44:36 ZergBuster login[1321]: PAM adding faulty module: /usr/lib/security/

I am now looking up why is ‘bad’, but so far, nothing obvious. I wish I could just ask pacman to reinstall it. Maybe I will also check if that can be done.

Thanks again!

I got it working, thanks to your pointer, cfinnberg!

I searched for “pam unable to dlopen”, and found that someone had grep’ed their /etc/pam.d/ folder for tally2, and I found two entries in system-login. I found the same, commented those out, rebooted, and was finally able to log back in.

1 Like

Just out of curiosity, didn’t you have some .pacnew files in /etc/pam.d?

1 Like

Yes, I did. I confess to not knowing everything I was doing there as it was the first time I used vimdiff. I had about 20 files that needed merging. I assumed it needed to be done manually, for each file, so it took a while, and at this point, I don’t know what changes I might have made to the system-login file. I also read through the wiki’s entry on managing the pacsave and pacnew files, but it was never clear when I should choose new over save, either as a complete overwrite, or on a line-by-line basis. Do you know of anywhere I can read up more about that?

In this specific case, would the release announcement have told me to choose the new over the save? It is it, perhaps, always best to overwrite with new?

It depends greatly on the file. Sometimes you just discard de new files, sometimes you have to merge and sometimes (like in this particular case) you can just replace de old ones with the new ones :slight_smile:

1 Like

I’ve got the same problem of not being able to login anymore after updating my system yesterday. This specific system is using manjaro budgie.

Gonna try your solution and will update my post later.

EDIT 1: Got the same problem pam unable to dlopen problem after looking in my journalctl.

Replacing old system-login with system-login.pacnew also resolved my problem

1 Like

I had the same problem, booting to black screen with cursor, no tty login possible.
After some searches found the solution explained in arch forum
Had to boot from USB and manjaro-chroot -a and
(move /etc/pam.d/system-login.pacnew to /etc/pam.d/system.login)

but this errors are in pacman logs, should i copy/move the rest too ? or open a new thread ?

grep pacnew /var/log/pacman.log 
[2020-02-28T08:30:53+0100] [ALPM] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
[2020-03-25T14:37:30+0100] [ALPM] warning: /etc/security/limits.d/10-gcr.conf installed as /etc/security/limits.d/10-gcr.conf.pacnew
[2020-06-02T21:22:06+0200] [ALPM] warning: /etc/shadow installed as /etc/shadow.pacnew
[2020-07-24T07:55:15+0200] [ALPM] warning: /etc/fonts/fonts.conf installed as /etc/fonts/fonts.conf.pacnew
[2020-09-02T06:52:53+0200] [ALPM] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
[2020-09-02T06:52:56+0200] [ALPM] warning: /etc/pam.d/system-login installed as /etc/pam.d/system-login.pacnew

and why does this happen ?

You did read the part about Manual intervention for PAM in the stable announcement right?

Did you do them?


I must admit: no. I am just working with manjaro for 3 years, never had a problem like this, so i am a bit lazy user. But i still think this should not happen at all.

But thx, i will read it now.

1 Like