After 19.01.2021 stable update no functioning network for specific programs

My browsers still connect fine using my vpn (using the mullvad client) but anything else, system, updates, steam… No internet. I can ping but not googledotcom, then Its says “Dienst nicht bekannt”.
I can’t update, nor use pamac.

sudo pacman -Syyuu

:: Synchronisiere Paketdatenbanken…
Fehler: Konnte Datei ‘core.db’ nicht von manjarodotmosondotorg übertragen : Could not resolve host: manjarodotmosondotorg
Fehler: Konnte Datei ‘core.db’ nicht von manjarodotre übertragen : Could not resolve host:
Fehler: Konnte Datei ‘core.db’ nicht von mirrordotalpixdoteu übertragen : Could not resolve host: mirrordotalpixdoteu
Fehler: Konnte multilib nicht aktualisieren (Ungültige URL für den Server)
Fehler: Fehler beim synchronisieren aller Datenbanken

sud pacman-mirrors -f

Pacman-mirrors version 4.19.1
::Downloading status failed!
::Please check you network connection …

cat /etc/resolv.conf


cat /etc/hosts

# localhost.localdomain localhost machine
::1 localhost.localdomain localhost machine

Thanks for not letting me post the whole output of Syu. I removed half of it and switched dots for dots because some smart man thinks posting links is suspicious.

Hi @zonk, and welcome!

I don’t know what your setup there looks like, but that sounds like a DNS issue. I would almost go as far as saying the VPN client is overriding and intercepting your DNS requests. Although I might be wrong about that.

Add the following in /etc/resolv.conf (You’ll need root access to do so.):


If is the IP address of your outbound router, it seems it’s not passing the DNS requests on to a public DNS server. The extra line just tells Manjaro if it does not get an answer from your router to send the request directly to google’s DNS server. (That you mentioned you could reach with a ping.)

Hope this helps!

I already did that, did nothing. I was googling for help before and this was one thing people sugestet. It is in my resolv.conf I just didn’t copy it over here to have kind of a fresh start. Before the update everything was fine, and there was no update for the mullvad client.

So disabling the vpn works. But that’s still weird tho because BEFORE the update, it worked.

Then it seems there is something wrong with your DNS software, seeing as everythhing worked with the VPN client active.

I’ve no experience or knowledge of thisso maybe someone could maybe help better, but try reinstalling, or at least reconfiguring, NetqorkManager.

Yea I was just reinstalling it. Works now. thanks.

Edit: Nope… It worked for half an hour or so and now the Problem is back… @Mirdarthos

Edit 2: I had to set a custom DNS server in the mullvad app… Now it works again… This is so weird…

1 Like