Advice for Best Experience on 49" 4K Monitor in 1080p?


I’m using XFCE on the latest version of Manjaro for ARM devices.

My target display is a 4K Sony 49". I’m using wireless HDMI, so I’m limited to 1080p, which is fine. Display compositing is disabled, because I found the desktop to be extremely laggy, and I’m rarely in here.

Problem 1: From across the room, the default settings (1x scaling) was … I won’t say illegible, because I could just barely read it, but trying to use a computer while having to almost-squint and carefully read the tiny tiny letters is not a good experience–or a safe one when doing things like tweaking firewall settings.

Solution: I set Display scaling to 2x, and am using the xhdpci default theme.

Problem 2: The menu bar and other UI elements are now large enough, but windows are huge. It’s like running in 640x480 on a 49" monitor. Which would be fine, except everything is gigantic and I’m actually running into issues with some apps not being able to run because even at full screen their windows can’t get big enough and throw an error.

Solution: I have no idea. Help?

I feel like I need 1.5x scaling, but that option isn’t available.

I am not sure you can manage 1.25,1.50 etc in XFCE.
But … heres to your luck starting from here, then also try the generic options below using xft:

I’ll check this out, @cscs. Thanks!

I mean, at least it’s legible?

Yeah honestly thats not too bad.
Maybe it is ok to then do some back-tracking tweaks … like lower font and icon size.

Oh … PS … for FF use this flag in about:config if needed:


And use fractional integers like 1.25 or 1.75 to set.

Thanks for the info, especially for Firefox. From what I can see, Firefox needs all the help it can get. Trying to run it with the compositor turned on nearly murdered the Pi.

Yeah, I an actually use it now, and it’s not like I can’t just shell in from another computer to use the terminal, which is what I do 99.5 percent of the time anyway.

I just figured there should be a way to hit a sweet spot with the scaling. On the other hand, I’m not sure it’s worth trying to hack on various Xorg files when everything is working at 1080p60 already. In my experience–more than a n00b, less than an expert–that’s a recipe for breaking things that are already working.

Here’s some info on the .Xresources user-level conf file. X resources - ArchWiki

Like, I don’t even have an .Xresources file in my user’s home directory. I’m kind of afraid to create one, at least not without a bit more research on what exactly it’s supposed to do.

Part of the issue is simply that XFCE isnt great with HiDPI
(hence the ‘need’ for specialized hidpi themes)

But as for .Xresources … its fine to create it … you probably already have a line in your ~/.xinitrc that tries to load it if present.

And of course … you can always just edit or remove it after creation :wink:

(also note the other options - for setting GTK and QT things using environment variables. Theres probably some sort of mixture that works well)

1 Like

Will experiment later. Thanks, again!

EDIT: @cscs , if I want to add environment variables that will launch with XFCE, which .dotfile is the best one to use on a per-account level? This HiDPI article has some specific suggestions for XFCE and various graphics toolkits (e.g., QT5).


I tried just using the 2x scaling with the environment variables from the ArchWiki article, but I’m not really seeing any improvement.

I also made the changes to Firefox.

(Firefox is awful on the RPi 4. I just ran a speediest at and it completely pegged my CPU at 99 percent, which of course held the test result artificially low. What.)

I found a great resource on the old archived Manjaro forums. Instead of using the auto-scaling, someone gave a step by step guide for customizing various aspects of XFCE individually, to get much better results–that is, you have a choice between “entirely too small” and “does anyone remember 640x480 ‘hi-res?’”

This is amazing, and the only reason I haven’t given up on XFCE entirely. Thank you, @dalto.

The only issue I still have is that window controls (maximize, minimize, close, etc.) are still too small. Apparently I need to pick a different theme, but I haven’t bothered with trying to fix it yet.

EDIT: If you use Chromium, you’ll also need to look at: HiDPI support in Manjaro - Tutorials - Manjaro Linux Forum . In particular, there’s a post at the tail end by @FadeMind re: setting Chrome/Chromium flags for high-res display.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.