Admin Password Not Working

Hello I am a new linux user and my admin password that I set is not working I do not know what to do please help.

The initial user is always a super user so you should just use the password for your username.

If you are referring to the root user - then you have set it during install - and you have either selected to use same password as your user or you have selected a different password.

With KDE you cannot always assume the requested password to be the user password - so if your user password is rejected try with root password.

In such case the only way of being sure is having a different passwords for root. Besides solving this kind of issue it is also better in terms of security.

it is asking me for the password to use the “sudo” command but I cannot type in the window also when I try to do other things that takes a password my username or the root password does not work

Your password, not your username and not the root password.

When I installed linux I did not put a password

sudo won’t give any indication of your typing: just type the password blindly and press Enter when done. As was already said, that would be your user password.

1 Like

During installation you have supplied the desired username - and you have been queried for a corresponding password.

Did you skip the password? I don’t know if it is even possible but if you did you are in for various kind of trouble as sudo will not accept a user with an empty password - and root without password is blocked.

It’s possible you can create user without password, sudo with this user work as with password user. But it may cause problems with lock screen :wink:

There are at least two possibilities to put or change sudo-password:
in Gnome: Settings → User (sudo-passwoed needed)
Manjaro settings: user accounts. (without sudo-password)
The latest Gnome-live-media do not ask for a root-password.
Then type in Terminal:
sudo su
(you CAN have a user-password AND a root-password)

Thank you for the comment.:slight_smile:

I have tested this and indeed it is possible to create user without password.

My reference to trouble did include your reference to the screen lock issue (I couldn’t remember the exact issue or topic).

Another issue when creating a non-password user - which will often include a password-less root user - and the last will prevent su -l root because password less root is blocked by default.

When you are using KDE as the OP indicates some system actions will be impossible because in the above situation because KDE will expect the root password no matter if the requesting user is superuser.

To work around issues with KDE which expects the root to execute the action - that you will need to apply a password to at least the root user.

$ sudo passwd root

Then press Enter with no password - and supply the new root password.

This may help - no guarantees though :slight_smile:

A word of caution

One of the reasons Windows has been the target of thousands of malwares is of course the dominant position Windows has but the initial cause has been the fact that Windows security for years was next to nothing.

A word of advise is - do not repeat their mistake by opening your system for malware.


Hurray! This working for me too. Not write any password, but at desktop when need update packages need pass, no chance to hit enter, it´s inactive button, in terminal too…

1 Like

I had the same problem. I have just installed Manjaro XFCE and “sudo” would not accept my password. (My user password is the same as the root password). The only way I could fix it was to “su -” and then to reinstall sudo,