Admin password blocking from performing any functions in Manjaro

Hi all,

I have run into a severe trouble and I need someone’s help to sort this issue. My son’s laptop is configured with Manjaro linux for him to learn and explore and is not provided admin access to it. Now the person who configured is not available anywhere and we have run into severe trouble. He cannot update the apps, and cant perform anything and is stuck right now. Any leads in assisting us to fix the issue will be of great help.

when booting press the shift key it will take you to grub menu
and then follow this guide

Just checking : has he tried to put his password when prompted for the admin password?

Yes. I tried with some of the passwords we use and finally could login. We did some long pending updates and post that couldn’t login back and getting Failed to start session. I’m trying to troubleshoot through tty2 with the help of community.

I did the command sudo systemctl status lightdm and getting some error.

gkr-pam: unable to locate daemon control file
gkr-pam: stashed password to try later in open session
pam_systemd_home(lightdm:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.

Please help me with this issue or any leads will be helpful.

Just to finish about that point.

There are two ways to use admin – actually superuser – features:

  • Login with the root user
    It is a specific user (the name cannot be changed) that is commonly created with the same password as the first user created for the system (in order words, at installation)
  • Access temporary superuser privileges with sudo
    Some users are part of the sudoers group – the group of users that can access sudo – and can thus temporarily gain superuser privileges when needed. In graphical applications, the user is usually prompted for a password (their own), in order to confirm their identity and gain those privileges in order to achieve the action they are ongoing.

Regarding your lightdm issue, i suggest you start a new thread, for clarity sake.
In the meantime, after login in tty, you should be able to start a graphical session with startx.