Activities in Gnome Shell broken with latest stable?

Confirm the issue. I am on Intel UHD 630 graphics if it does matter. I tried other kernels, switched from Wayland to X session, but problem remains. The only workaround is to log out.

2 Likes

same problem. even sometimes i dont need to click on 'Show application button" it just freezes if i have opened more than one app.

1 Like

Hi all in this thread :wave: , this post in the stable update thread points to a possible solution.

1 Like

I think this is happening to me. The task switcher (Activities or whatev) usually works for me but a few mins ago, I pressed super or clicked (I forget which) and the thing would now allow me to return to the desktop. I had to logout and back in. This is a fresh install w/updates.

is there a log for that feature?

I switched the layout to gnome and everything is fine now. Can someone verify?

The problem is that i can’t reproduce the bug…
I think it arrive randomly, but, if someone can repoduce it as he wants, it could be useful to correct it.

Same thing happening here. Apparently it happens kind of randomly, and it can be by using the hot corner, or the super button. The only way to get out of it is by logging off.

I’ve read several times to limit the gnome extensions to the ones available in pamac. These are tested by manjaro team members, and one can manage it with Extensions gnome app. Give a try to remove all web-installed ones ? Plus we are in the process to move to gnome 40, extensions devs will have to check if it is compatible with.

1 Like

Hey guys,
I have the same problem as well, I don’t know why but GNOME’s Activity menu just breaks on my Manjaro stable release install.

Does the solution @hb01 posted work for you?

If this is a fresh stable install I’d post it in the release thread with info about the running extentions, your inxi and some logging

i reinstalled the manjaro with a new iso downloaded from the manjaro website. “A clean install” worked well. After that i played around With the gnome extensions a bit mostly the dash to dock and issue reappeared.
The i switched to the Gnome layout and the issue is resolved. I also noticed that the extensions enabled were dynamically controlled by the layout switcher.
I suspect this might be an issue with some unsupported extension feature which is not used by the gnome layout, It may not be the issue with the Gnome itself

I’m facing the same issue. Tried installing multiple times, it’s in the stable release 21.0.5. This needs to be fixed as soon as possible.

Facing the same problem Actually faced it multiple times by now. I am stuck at the activities panel right now as I’m writing this comment from my phone. I would log out / reboot to fix but unfortunately I have queued 20 app installs

@megavolt give a solution :
That happens sometimes when the GPU is overloaded. At least in my case.

To solve it i press the keystroke :

ALT+ F2

and type: restart OR just r and press ENTER

It will restart/reload the gnome-shell without closing any apps.

@cyprien Better use quote like this :wink:

However… i experienced the same problem when switching layouts. When no windows are open and i switch the layout then everything is fine. But if there open windows, then the gnome-shell just needs to be restarted (refreshed).

If you go to GNOME Tweaks → Top Bar the first option is Activities Overview Hot Corner. Toggling this to off keeps me from getting stuck in the Activities overview and having to log off to recover. In the ArcMenu settings → General there is also an option to modify what the Activities Hot Corner does, changing to anything other than the GNOME default also prevents problems.

I’m using the “Traditional” layout if that make a difference for any of these settings. I have no idea why this problem occurs in the first place, this is just how I get by for now.

I got the same issue here. The hot corner opens up, minus the virtual desktops on the right and only allows closing windows. Not switching windows. Only a reboot clears the problem.

I have same issue. I don’t think so it caused by hot corner. It also happens to me when i click windows button on my keyboard. Maybe it has something to do with GNOME and not only some extensions, but i will try to turn off hot corner.

Have you tried
ALT+ F2

and type: restart OR just r and press ENTER ?