Activating Present Windows Crashes KWin/compositor

Hi all. Anyone else experiencing following bug (number 425054 in the KDE reporter)? Since 5.19.3 dropped on Manjaro, I am getting KWin/compositor crashes with Present Windows (expose) being repeatedly activated by hot edges. Usually it’s when activating and then rapidly retriggering the same edge to deactivate the effect. Upon deactivating Present Windows, I get no animation and return to the last active app to find the compositor has crashed. Sometimes KWin will start itself, sometimes I need to manually turn it back on from system settings.

Sadly, as my workflow in my job requires rapidly switching between active windows and copying and pasting between them, this is really a big deal. I can’t have KWin/compositor crashing every every 5th or 6th activation. Has anyone been able to find a fix? If I can’t resolve this soon, then I’ll have to switch to Gnome or some other DE which, after about 2-3 years of happy Plasma use, would make me deeply sad.


Hello iiari,
the new one should actually be 5.19.4 so please update your system
sudo pacman -Syu

I would first try reinstalling kWin with pamac reinstall kwin kwindowsystem

Don’t give up yet :wink:

Thanks for the reply. I’m already actually at 5.19.4 (the point update didn’t address it) and have reinstalled KWin without benefit. I also tried KWin Low Latency without benefit, and think this must have to do with something else. In fact, I tried booting the Manjaro KDE iso itself and the problem is reproducible there as well. I love Manjaro and love KDE and donate to both projects but I may have to bow out and go Gnome or use a different distro that’s still on, say, 5.18 until this is worked through, although the bug tracker seems to show no one is working on this yet. The relatively low number of reports also seems to suggest this isn’t a widespread issue, and thus may be low priority, but it’s a showstopper for me at the moment. I was hoping someone here found a workaround…

Can you explain what you mean, if there are settings to apply or something to reproduce your issue?

Sure. One of the other users submitting to the bug report described it best, with some clarifications from me, “Repeatedly triggering a hot corner set to present windows - all desktops [or just current desktop windows] can cause a crash. Triggering the hot corner once or triggering the corner and then selecting a window never causes a crash - but triggering the corner and then triggering it again while the windows are still presented [in expose display] causes a crash frequently. KWin must then be manually restarted. If the crash happens multiple times, KWin will be turned off alltogether and the “Enable Kwin on Startup” setting must be re-enabled.” Reports are from across different distros, so it’s not just Manjaro.

So, basically, using a hot corner to activate expose mode and selecting a window is fine. Using a hot corner to activate expose mode, and then selecting that hot corner again to deactivate expose mode and go back to the last app will often crash KWin.

Considering my workflow all day is switching between a half dozen different windows/apps constantly, having KWin crash every few minutes and slow the system down a bit more each time is hard…