ACPI.sys: How to disable an interrupt in Windows as we do in Manjaro?

I got a OS-agnostic problem of ACPI sitting atop a CPU core, producing ~11% CPU usage all the time.
The problem seems related to adding a second, 1TB SSD (Intel SSDPEKNW01) to the system, a P65_67RSRP notebook.

The question is, I was able to fix the problem in Manjaro quite easily by disabling interrupt gpe6F (using command echo "disable" > /sys/firmware/acpi/interrupts/gpe6F ).

In Windows, I tried every solution I saw out there: BIOS updates, driver updates, changing power management options for each device that had the option in device manager, etc, to no avail.

I couldn't find a way of reproducing that same fix on Windows. Does anybody know how to do this?

Removing this drive isn't quite an option.

I used MS performance toolkit to get to this:

Image

I couldn't go any further.

Has anybody a solution for this?

A couple of ideas:

1 Like

That's a must default for me if I want to access my NTFS partitions properly from Linux, so, it's disabled.

That's awkard: I found a tool to measure it and I'm not sure what's the 100% value for my fans. :grimacing:
image

That's the tool I used to generate the image in the OP. ACPI.sys!RunContext seems to be the culprit, but I don't know what to do with this info.

Oh, I went through that post. Intel SSD, it seemed the perfect fit. I did install the said driver. It didn't work: image :frowning:

Any further tips?

Thanks for the answer!

Maybe post on the Microsoft forums? There are still a few users on there that have half a brain left in my experience. They might be able to help.

1 Like

I've already done that. And to /r/Windows10 on Reddit. And to superuser.com.

There are a lot of smart people among Windows users. But this issue is really making feel as the smartest person in those rooms, and even so not even close to smart enough. :frowning:

1 Like

The only thing I can come up with is to poke around in the registry, which it looks like you’ve already done. You may have come across something Windows just can’t do. :man_shrugging:

Edit: Try

sfc /scannow

and

DISM.exe /online /cleanup-image /restorehealth.

Actually, I didn't mess with the registry yet. The registry is savage. Either you know where to look for something and how does it look like, or there's not much you can do.

Linux is simpler and better organized. And better.

No bonus. It's still bad.
It's so frustrating to have such a simple and straight-forward sollution in Manjaro but not in Windows...

Well, it looks my original premonition was right, I did some searching on the web since I was curious, and it seems most users who had this issue had to track down the offending hardware piece causing the issue. Don’t feel bad though, I’ve found posts from 5 years ago complaining about similar things. It appears that like I said, you have come upon an issue that Windows just can’t fix.

I did find a Dell thread about disabling ACPI.sys (for a different issue) but TBH it seems like a really risky/dangerous thing to do. I think it would be best if you just let it be, instead of potentially nuking your Windows install.

While #other-os exist it is not for support threads.

Support for other operating systems must be sought within the operating systems normal channels.

Forum kindly sponsored by