ACPI Errors

faq

#1

“ACPI Errors” normally show up when the kernel adds support for newer hardware. The hardware might not be fully supported, or may be able to report more information than before, so while switching to an earlier kernel series will remove the message that’s because it offers less hardware support.

ACPI Errors can normally be ignored.

ACPI Errors will not normally prevent your system from booting so you should look elsewhere first.


After packages update of October, 8, Manjaro won't start normally
Unable to boot ..."machine has amw0_guid1"
Linux44 - corrupted package?
Kernel error acpi MSFT0101
ACPI Error clevo
#2

Mhh, actually errors come and go, more because acpica guys are still experimenting a lot with module level code.
Even super-duper old hardware could experience shifts.

Then some specific driver might decide to touch a picky section of the tables, and you’d be right.

But I wouldn’t bet on that “won’t prevent system from booting”.
(funnily, just two releases ago, my computer stopped to boot because the i2c controller that never worked, was finally getting discovered - but the underlying driver had never been ready for it)

Personally I’d always recommend to test version, newer