Acidentally killed bluetooth when trying to pair xbox controller with my laptop

So I was trying to pair my xbox controller, but it wouldn’t find the device

So I tried installing xpadneo thru yay:

sudo pacman -S dkms linux-headers bluez bluez-utils


yay -S xpadneo-dkms

Then I rebooted, but now the bluetooth icon has vanished, and “bluetooth” under system settings says no bluetooth adapter found.

When I type:

sudo bluetoothctl, it just says “Waiting to connect to bluetoothd…”
I also tried these:
sudo systemctl enable bluetooth.service
sudo systemctl start bluetooth.service

still no bluetooth :frowning: how would I be able to restore my bluetooth? thanks!

I typed:

/usr/lib/bluetooth/bluetoothd -n -d

and it says:

D-Bus setup failed: Connection “:1.111” is not allowed to own the service “org.bluez” due to security policies in the configuration file
bluetoothd[11760]: src/main.c:main() Unable to get on D-Bus

please check that it is not still blocked as described in the link

I did that but it didn’t help :frowning:

rfkill only returns
1: phy0: Wireless LAN

no bluetooth

did you try

 sudo systemctl restart bluetooth

Yep, nothing.

inxi also shows:

Bluetooth: Message: No bluetooth data found.

bluetoothctl list also shows an empty list

bluetooth --help shows:
bluetooth = none (no device)

It looks like Bluetooth is completely dead… it was working as active when I initially installed it but it never worked. could it be my ASUS laptop?

" Start the bluetoothctl interactive command. Input help to get a list of available commands.

  1. (optional) Select a default controller with select MAC_address.
  2. Enter power on to turn the power to the controller on. It is off by default and will turn off again each reboot, see #Auto power-on after boot.
  3. Enter devices to get the MAC Address of the device with which to pair.
  4. Enter device discovery mode with scan on command if…"
    Bluetooth - ArchWiki

sudo bluetoothctl
Agent registered
[bluetooth]# power on
No default controller available
[bluetooth]# devices
No default controller available

it’s dead :frowning:

try further and use the scan option as described

Same error… my bluetooth adapter isn’t being detected

Ehhhh this is odd. I booted into windows, paired my controller, then back to linux and suddenly Bluetooth worked and I was able to pair the controller

1 Like