Acer One 14 Z1402 can't use keyboard and/or mouse in Manjaro XFCE

First, forgive my bad English. I’m from Indonesia.
I’m new on Linux and I have my old Acer laptop which I use to watching movies, listening to music, and sometimes to edit subtitles. As long as I use this laptop for Windows, it’s going fine, every hardware working normally. But when I start install Linux on this machine, I found that keyboard and mouse is not work. I was try at last 4-5 distro: Fedora, Ubuntu, openSUSE, Xubuntu, PCLinuxOS and ZorinOS. For Manjaro, I was try with Gnome, KDE, and now I use XFCE desktop environment. But nothing between all of them can use my keyboard and mouse laptop. And I once try to change kernel, from 4.x.x until now I use 6.x.x and nothing use. What can I do for make this keyboard/mouse to work? Thank you for your kind answer.

Hello @pasukanmati and welcome :wink:

A good starting point would be to know if the keyboard or mouse works, when you boot up the Manjaro ISO. So actually the boot menu when you choose how to boot the live session.

Disable “fastboot” or “partial initialization” (however it is named on your system) in the UEFI/BIOS Settings, which skips some devices on boot time to speed up. This is a common issue and difference between how Linux and Windows recognize devices.

Also disable secure boot in the UEFI/BIOS completely, since Manjaro has no support for that, and that can forbid Linux to access some devices.

Attach a keyboard and mouse via USB and check if that works (commonly it should).

It could be possible that there is no driver available for your integrated keyboard and touchpad in Xorg. That have to be verified.

Please attach full system information, if possible. Open a terminal and run:

inxi --verbosity=7 --admin --filter --width

and attach the information here in a code block.

Hope that helps to start troubleshooting.

Thank you for answer.
There is no fast boot and secure boot setting on this laptop, although I can use UEFI - I am not sure whether I install Manjaro XFCE with UEFI or Legacy Boot, but it seems that both of them are going well. Unfortunately I didn’t try live mode and went straight to the installation process. So I didn’t know whether the keyboard and touchpad work or not in live mode. The USB keyboard and mouse work well. Here I attach my full system information.

  Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=1814e187-90a4-4175-acb4-0ee530c257df rw quiet apparmor=1
    security=apparmor resume=UUID=a7d8af03-61bb-4597-96fd-b8897d9ce245
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: One Z1402 v: V1.07
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Acer model: One Z1402 serial: <superuser required>
    UEFI: American Megatrends v: 1.7 date: 11/02/2015
  ID-1: BAT0 charge: 14.1 Wh (87.0%) condition: 16.2/23.8 Wh (68.2%)
    volts: 12.6 min: 10.8 model: standard type: Li-ion serial: <filter>
    status: charging
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 1.78 GiB used: 1.03 GiB (58.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Celeron 2957U bits: 64 type: MCP arch: Haswell level: v2
    built: 2013-15 process: Intel 22nm family: 6 model-id: 0x45 (69) stepping: 1
    microcode: 0x26
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 2 MiB
    desc: 1x2 MiB
  Speed (MHz): avg: 799 high: 800 min/max: 800/1400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 798 2: 800 bogomips: 5589
  Flags: abm acpi aperfmperf apic arat arch_perfmon bts clflush cmov
    constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb
    ept ept_ad erms est flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs
    invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr
    mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge
    pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good sdbg sep ss ssbd
    sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer vme vmx vnmi vpid xsave xsaveopt xtopology
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Tongfang Hongkong
    driver: i915 v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports:
    active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0a06
    class-ID: 0300
  Device-2: Acer VGA Webcam type: USB driver: uvcvideo bus-ID: 2-7:4
    chip-ID: 5986:065e class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: crocus gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: AU Optronics 0x323c built: 2013 res: 1366x768
    hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
    ratio: 16:9 modes: 1366x768
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Haswell-ULT HD Audio vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c
    class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20
    class-ID: 0403
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Tongfang Hongkong driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.1 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0f1 state: down mac: <filter>
  IF-ID-1: wlp0s20u1i2 state: down mac: <filter>
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig
  Device-1: Realtek RTL8723BU 802.11b/g/n WLAN Adapter type: USB
    driver: btusb,rtl8xxxu bus-ID: 2-1:2 chip-ID: 0bda:b720 class-ID: e001
    serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 476.94 GiB used: 361.07 GiB (75.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: EYOTA model: 512GB size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 704G scheme: GPT
  Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW SU-208GB rev: TC00
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 472.72 GiB size: 464.23 GiB (98.20%)
    used: 361.07 GiB (77.8%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 1814e187-90a4-4175-acb4-0ee530c257df
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: EE51-7CC7
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 3.92 GiB used: 1.8 MiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3 label: swap
    uuid: a7d8af03-61bb-4597-96fd-b8897d9ce245
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Hub-3: 2-0:1 info: Hi-speed hub with single TT ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 2-1:2 info: Realtek RTL8723BU 802.11b/g/n WLAN Adapter
    type: Bluetooth driver: btusb,rtl8xxxu interfaces: 3 rev: 2.1 speed: 480 Mb/s
    power: 500mA chip-ID: 0bda:b720 class-ID: e001 serial: <filter>
  Device-2: 2-2:3 info: Logitech Unifying Receiver type: Keyboard,Mouse
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c534 class-ID: 0301
  Device-3: 2-7:4 info: Acer VGA Webcam type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 5986:065e
    class-ID: 0e02 serial: <filter>
  Hub-4: 3-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 158 Uptime: 56m wakeups: 5 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1134 libs: 322 tools: pamac pm: flatpak pkgs: 0 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.25

Possible that both or one of them are there, but there is no switch, since it is a low-budget laptop. :man_shrugging:

I cannot believe you install Manjaro XFCE on such a system. 2GB RAM is really low (can you even work with that?) and then you run one of the latest kernels v6.1.

Maybe try different kernels, that can done with mhwd-kernel or the there is GUI “Manjaro Settings”.

sudo mhwd-kernel -i linux515

On boot time, you have to choose the newly installed kernel on the boot menu.

At least, you can work with n external keyboard. Please share information about the input devices:

 sudo libinput list-devices

If the integrated keyboard is in the list, you can test it:

sudo libinput debug-events --device /dev/input/event<insert number>

Plus, since you use Xorg and XFCE, have a look at the log:

cat /var/log/Xorg.0.log

Yeah, only 2 gigs of RAM, but the system works flawlessly. It’s only 850 MBs RAM consumed when system boot to desktop, one great thing for the Manjaro XFCE system, I think, compared to when I use the GNOME desktop which consumes 1.1 GBs of RAM. I can watch movies and TV shows with Kodi that I just updated to Nexus 20, then work on documents with OnlyOffice—want to switch to LibreOffice, since OnlyOffice can’t adapt to system themes. And all is well, no errors, no bugs, no crashes, only occasionally Kodi crashes on program exit, and I found Kodi can run its own session in addition to the Xorg session.
The only problem I have is that I can’t use integrated keyboard and touchpad which I find very inconvenient having to use an external keyboard and mouse.
FYI, I had try all available kernels in my system with Manjaro Settings Manager, even for version 4.19.272, installed it and boot with. But nothing happened, keyboard and touchpad still not work.
I’ll try that later, since I’m out.

Thanks for all your suggestions. After trying to change the kernel many times, finally the keyboard and touchpad on this laptop were detected and worked fine on kernel 5.4.231-1. It’s funny because I’ve tried this kernel before, or maybe I’ve missed something. Regardless, thank you very much.

That’s a bit of a record for a fully running Xfce. Still, browsing can’t be much fun. Have you considered upgrading your single ram chip?

Your lap supports 8GB max (Acer One 14 Z1402 Price (05 Mar 2023) Specification & Reviews । Acer Laptops) and this will make a huge difference. An 8GB DDR3 PC3L-12800 204pin bank is new about 20 $ or around 10$ used. The upgrade should take about 15min: Acer One 14 -- Z1-402 Replace/Ganti/Upgrade SSD & RAM - YouTube .

Yes, you are right. This laptop supports up to 8 GB of RAM. Maybe I’ll upgrade it later. And browsing with Firefox is still relatively comfortable to use with two or three tabs opened.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.