Acer Nitro 5 Audio sounds odd


#1

This is my first time using Nitro 5 to run a linux distribution.
My Nitro 5 has specs:

  • Model : AN515-52-52LD
  • Intel i5 5300H
  • Intel HD 630
  • nVIDIA GeForce GTX 1050M
  • Realtek ALC255
  • OS : Manjaro Linux 18.0.0, Linux 4.19

There are numerous problems I had faced but I can’t seem to solve this problem. In Windows, the speaker sounds amazing, in manjaro it just sounds terrible as if the speaker is not properly placed (also affects earphone).
I have tried the audio improvement using pulseaudio configurations (without equalizer) and the sound quality improved just by a bit. It’s hard for me to describe the sound, the sound loses a lot of details which makes the vocals and instruments hard to be heard.

I’m not sure what other detail or log i need to provide so please tell me what else I need to try.


#2

You might be able to find something by searching for your audio chipset.

If you can’t describe the issue then I think the only way for anyone else to help diagnose this will be for you to record some examples so they can be compared.


#3

maybe helpful? my Nitro AN515-51 sound ok through last several kernels, running 4.19.

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

lspci
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)

#4

Anything weird?

lspci 
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

#5

Since I deleted the preinstalled windows 10 already, it’s hard for me to give the audio sample between windows and manjaro.


#6

OK, but you can still give an audio sample of the issue.

It’s like trying to discuss someone’s painting over the phone. “I don’t like the blue I’ve used over here… and the shape of this bit isn’t quite right… how can I fix it?”


#7

Okay, while i tried using Windows on Virtualbox. It sounds fine.
I don’t know why in Manjaro the bass and treble is out of control.


#8

The audio subsystem is the same for both the host and guest OS which leads to the questions - what are you playing, how, and what changes have you made to the system?


#9

I’m sorry. The VM do show different result. but the speaker really sound worse. So, it’s not only about the soundcard.