Access Synology NAS (DS218)

Hi all,

I have setup my DS2018 quite some time ago. Making a folder for myself outside of homes (which I overlooked at the time). This is what the fstab looks like:

<name of server>:/volume1/<name of my folder> /home/NAS nfs proto=tcp,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min,retrans=5,retry=0,vers=4,nofail 0 0

And gave my user acces rights to that folder.

Everything runs as it should and I have access from my linux PC,

We are getting to today:
I wanted to see if I can move my stuff to the folder the NAS was designed to work with (/homes/).
So I added a line to the fstab accordingly (just to see if everything works fine):

<name of server>:/volume1/homes/ /home/Wolke nfs proto=tcp,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min,retrans=5,retry=0,vers=4,nofail 0 0

I have not given any permissions on the NAS on my first try, as I can only give permission on the “homes” folder, but not the user ones (but I guess, that is automatically done, right?).
On my 2nd try I have given R/W access, but the error messages on my linux stays the same:

mount.nfs: mounting <name of server>:/volume1/homes/ failed, reason given by server: No such file or directory

Right now I have no clue what I’m doing wrong, especially as everything worked how I did it before.


if /volume1/homes exists
then I can only think of the trailing / behind /volume1/homes
you put it like /volume1/homes/

That sounds really strange to me - a folder name that it was designed to work with.
Especially when it clearly did work without it …


/homes is the generic folder where every user that is created gets his own folder.
e.g. /homes/smith or /homes/oliver
I’m not sure if that folder is case sensitive, but as the others aren’t why should it.

The access which is already working starts with /volume1/, so I assume, that homes works the same, but I could be mistaken.

I have tried volume1/homes and volume1/homes/ both and both with trailing “/”. I’m getting the same error message.

I’m going to re-read the DS218 help files. Haven’t found anything so far, but maybe I have overlooked something.

The /homes folder is not accessible - the system permissions will not allow it.

nas> uname -a
Linux nas 3.10.35 #5967 SMP Fri Nov 3 17:21:46 CST 2017 x86_64 GNU/Linux synology_x86_1010+
nas> ls -la /volume1/homes
d--x--x--x    7 root     root          4096 Feb 16  2022 .
drwxr-xr-x   21 root     root          4096 Dec  6 10:00 ..
drwxrwxrwx    3 root     root          4096 Dec  6 10:00 @eaDir
drwx--x--x    7 AH       users         4096 Dec  2  2016 AH
drwx--x--x   13 FH       users         4096 Sep 19  2020 FH
drwx--x--x   11 admin    users         4096 Oct 13  2020 admin
drwx------    3 plex     users         4096 Aug 17  2019 plex

And you should not experiment with system permissions.

You can share a user’s home folder and/or sub folders.

But not the /volume1/homes folder - as it is not readable for users - it makes sense as a NAS is typical multi user system and listing the /homes folder would reveal the usernames on the system.

1 Like

I have found this:

Download-Zentrum - download | Synology Inc.

section 5.1
points to
section 2.10

You have to activate the home - folder for your nas - users.

Look here:

Then you can insert an entry into your fstab like this:

// /home/caho/NAS-2 cifs x-systemd.automount,credentials=/home/caho/.smbcredentials,iocharset=utf8,nounix,file_mode=0777,dir_mode=0777,nocase,noserverino,mfsymlinks 0 0

Now you are conected into your users - home - folder. Other users cannot see this folder. You need an entry in the fstab for every user who will use the nas - home - folder.



I have just read something similar in a forum.
Explains my difficulties…

  1. what is the home folder? It’s not part of the “shared folders” How would I access that folder via nfs?
    I have created my own shared folders, which works fine, but I’m getting the nagging feeling I made a huge mistake.

  2. What is homes for than? Which leads to:

  3. Within the folder structure e.g. “/homes/oliver”, there are subfolders created by the system, like Drive. That was created, because the user oliver should be able to use the Synology app Drive. How do I access this folder, or did I do something wrong

  4. Are you referring to the user handbook ?

I did activate the home option during setup in 2018. But those “home” folders are created under homes.

If I log into the DS218 I get a home (not homes) folder, which I guess is the same as the one I’m seeing under homes, but I have no way of accessing it from my linux maschine. At least not using nfs.
I haven’t had the time to read the difference to cifs, but using nfs I can mount /home. I’ve tried that too:

sudo mount -t nfs -o rw -o vers=4 :/volume1/home /home/Testwolke

I’m trying to understand, but I seem to be missing a key part of the puzzle.

Would screenshots help in understanding were I’m getting confused?

If you can’t figure out how they are configuring the system
based on your input in their GUI
to accommodate multiple users
… and if you actually don’t even need to - because you may be the only user …

Why not just keep using the thing in the configuration state that does work for you?

… the users $HOME folders are (seem to be) located below the
directory structure
where each user then has got an individual home directory
which you then can mount

not /volume1/homes
but individual directories below that

I don’t have such a thing - only the manual I linked to.

If it works for you as it was … why change it?

1 Like

Hello @EdwardHyde,

as you can see in the fstab - entry in my first post there is a section “.smbcredentials”.
This is a little file in your local home-folder. It includes two entries:


This are the login - datas for your nas- login.

When you boot your computer, fstab send the login - data from .smbcredentials to the nas. If the user exists on your nas and if you activated your home - folder, then you are connected.
The fstab - line in my first post is a copy from my local fstab and works fine.

When you are loged in into your DSM, then you see the folder “homes”. This folder includes all individual home - folders for each user.

If you want to mount a common folder , then you can use for example this fstab - entry. It works fine on my computers:

// /home/caho/NAS-2-Bilder cifs x-systemd.automount,credentials=/home/caho/.smbcredentials,iocharset=utf8,nounix,file_mode=0777,dir_mode=0777,nocase,noserverino,mfsymlinks 0 0


1 Like

I’m not the only user. My wife is using this one too and we have a shared folder. It’s “primitive” but it works fine.
I was always wondering what the homes folder was needed for and thought I setup the system the wrong way…
I need to read that documentation, but I’ll have to put that on the back burner, as there are, as usual to many things to do.

I really appreciate the help I’m getting!

The individual home folders are very useful. Every user have its own folder for default.

Therefore is the home folder is not visible for the other users. There is no access for other users. And it is not shown in the network. So it is very safe. If somebody visit your network, he cannot see, wich users are present on your nas.

The login - datas to the nas are not shown in fstab. Only the path to the .smbcredentials in the local users home folder is visible.

This is the perfect folder for your personally, private or secret files and folders.

The shared folders should be used for files and folders to share them to all users like music, pictures, videos and so on.

Every user need an individual line in the fstab to use its home - folder.

I hope I could help you a little bit :grinning:


1 Like

There is no problem in creating you own shared folder - just use the gui to do so.

Also - the sharing of the folder using nfs is also done through the gui.

The homes folder serves the same purpose as /home on your manjaro but it is located differently on a Synology NAS.

I have +10 years of experience with Synology systems and I like to think I know my way around it.

There has been some GUI changes from DSM5 to DSM6 and one thing to dislike is how Synology forces new hardware onto enduser if one want to update DSM5 to DSM6.


I have never doubted, your or any of the others user experience here (hope it didn’t sound that way). I’m just missing that experience and try to understand the concept behind it.

I have found one mistake I made. I didn’t set NFS right on the home server. I did that to the other folders which are working. I have correct that mistake, but sadly no change in behaviour.

Definitely. I’m gald that experienced user help “dumb wits” like me. I have no clue how I actually made it to configure the NAS in the first place. :sweat_smile:
I think I had more time on my hand. Now my job and my family is keeping me busy, limiting my time to search the web and read manuals.

1 Like

In DSM → Control Panel → Shared Folder

DSM 5 screenshot


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.