Absolutely horrible performance on fresh install

So i’m thinking of using manjaro but the issue i’m having is that after installing the os the whole system runs at maybe 2fps and is un-usable and the cpu is at almost 100% all the time, this issue does not appear in the preview when booting off usb but only after proper installation.

I’m on kubuntu right now so this does not appear to be a kde issue at least to me and also because i had to swap os i can’t provide any terminal outputs unfortunately.

My system specs are Ryzen 7 3700X, 32gb of ram and an RTX 3060TI.

Can you post some mor hardware info ?
Also on Kubuntu ?

What type of hardware info do i need to post and how can i aquire that info?

inxi -Fza on console.

Maybe the Nvidia driver is not installed.

The website says i can’t have links in the post but i don’t think it has links since it is just the output of the command you said to run.

On what process? check (h)top

Run the command Keruskerfuerst gave you in a terminal:

inxi -Fza

And then copy the output (text) to here. The output is quite long (at least you have to scroll to see it completely). Use the “preformated text” option from the forum editor to format correctly the copied text.

If you are running KDE Plasma you probably are going to want to disable Baloo indexer with the command:

balooctl disable

…its pretty tame once its done the initial index I find.

1 Like

You are right, but I just mention it because I see many first time KDE users wondering about the performance during the firsts hours/days of Plasma use and in many cases is just the indexer.

At leat the OP can try with Baloo disabled to see if anything changes.

Its all going to wayland, does this mean it’s because i don’t have gpu drivers installed?

I find baloo only needs to be temporarily disabled. Last time I did a fresh install, I re-enabled it just before I was finished using the computer (bed time) and it’s behaved ever since.

Nvidia and Wayland is difficult - to say the least.

The opensource nouveau driver can be a real pain with newer Nvidia GPU.

Not really, it can be just Wayland is still not ready for the prime time on your specific configuration. X11 is still the way to go at this very moment for KDE Plasma. The devs are pushing for Wayland in Plasma 6, until then, I suggest sticking with X11. Note: You can have both session installed so you can switch back n forth to see if it’s already worth it to move to Wayland.

Manjaro KDE from version 22.1.2 have Wayland as default, so after installation. In live mode it is always X11.

I use a GTX 970 under KDE Wayland without problems, but had to do the following:

Under /etc/default/grub
I have nvidia-drm.modeset=1 added, then looks like this:


In /etc/environment:

I don’t remember where I got this setting from. :sweat_smile:

Since then Wayland runs without problems under KDE. But with Nvidia cards the night mode does not work under Wayland yet.

Maybe this will help someone here. :slightly_smiling_face:

No - you choose which to use when before login.

W comes before X - so if you don’t change before login - you will run on Wayland - which canb be a troublefree expereince - depending on your system.

My system works flawless using Wayland - yours may not - but that is not a flaw of Manjaro - but the combination of hardware you have chosen.

Yes, that’s right, I had perhaps expressed myself incorrectly. Of course you can choose between Wayland and X11, but Wayland is selected by default.

That is not the work of Manjaro but displaymanager logic - it list available sessions in alphabetical order - hence Wayland is before Xorg.

The display manager remembers the last chosen session so next time it will default to whichever session that was - which could be Xorg.

I am says this because the word - default - suggests a deliberate choice on Manjaro side - which there is not.

It can be compare to LXQt - which usually comes with Openbox window manager - in which case you can choose between Openbox or LXQt sessions

Since I’m also playing around with nvidia and wayland, let me add my experience.

I do NOT load sddm into wayland yet, I will try that soon too.

I wouldn’t say the user experience in wayland with nvidia is “horrible”. You will most likely experience glitches as flickering, strange positioning of windows and other small things like that.
Nightmode as mentioned above does not work (is addressed by kde team HERE and will be handled in upcoming updates)

For me, it also stopped me from using my favorite mediaplayer smplayer, but others like mpv and vlc still works fine.

I feel wayland is way more responsive though, like moving windows, moving cursor over applications menu etc feels “snappier” over all.

If I log out of the session, and then log in again, I SOMETIMES have to type my password twice, creating two instances, sometimes on the same tty (but suspended), sometimes on different ones etc, its just a mess. And if I then try to reboot/shutdown, the sessions don’t close down properly, changing to tty1 usually immediately finishes the shutdown/reboot process.

So I would say that as of this date, sure, install it in parallel and play around with it, but if you want a flawless experience, wait a few more months and stick to x11 for now.

Edit. Oh yeah, fogot the dealbreaker for me. Sometimes programs just stops responding properly (usually firefox but other apps have also been affected by this), creating a loop for the cpu for a while, then sometimes coming back (or I have to kill the process). That causes the icons on the KDE panel to freeze up, and if I close the program, I can’t open it from the panel any more.

I don’t have these, so I will try and see if that changes anything for me.