About KDE Open dialog box Image thumbnail view

Hello everyone :
Just installed Manjaro yesterday .( KDE Plasma )

I’m facing this problem when I try to upload an image or send an image via WhatsApp or other social media. Can’t see the thumbnail view.

I was hoping it can show like in default Dolphin file manager .( Like this )

Do I need to enable some settings? ( I’ve installed Plasma integration and plasma-browser-integration package as well ). And I’m using Vivaldi at the moment.

And here is my Terminal inxi --full --verbosity=7 --filter --no-host output

System:    Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 
           info: plank wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: X299 AORUS Gaming 3 v: N/A serial: <filter> 
           Mobo: Gigabyte model: X299 AORUS Gaming 3-CF v: x.x serial: <filter> UEFI: American Megatrends v: F8l 
           date: 11/28/2019 
Battery:   Device-1: hidpp_battery_0 model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
Memory:    RAM: total: 15.58 GiB used: 4.63 GiB (29.7%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Info: Quad Core model: Intel Core i5-7640X bits: 64 type: MCP arch: Kaby Lake rev: 9 L2 cache: 6144 KiB 
           bogomips: 32013 
           Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
           clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c 
           flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt 
           invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe 
           pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good rtm sdbg sep 
           smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer 
           vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte driver: nvidia v: 455.38 bus ID: 01:00.0 
           chip ID: 10de:1c82 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia resolution: 1: 2560x1440~60Hz 
           2: 1440x900~60Hz s-dpi: 107 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a2f0 
           Device-2: NVIDIA GP107GL High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fb9 
           Sound Server: ALSA v: k5.8.18-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           chip ID: 8086:15b8 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 689.33 GiB used: 79.83 GiB (11.6%) 
           ID-1: /dev/sda vendor: SanDisk model: Ultra II 240GB size: 223.57 GiB speed: 6.0 Gb/s serial: <filter> rev: 00RL 
           scheme: GPT 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> rev: 2B6Q 
           scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f020 bus ID: 00:17.0 chip ID: 8086.2822 
           rev: N/A 
Partition: ID-1: / size: 448.50 GiB used: 71.77 GiB (16.0%) fs: ext4 dev: /dev/sdb2 label: N/A 
           uuid: 5562e046-ba95-4ea9-96f6-e68ff8030081 
           ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/sdb1 label: N/A uuid: 913B-978D 
           ID-3: /run/media/notorios/INLINUX size: 219.06 GiB used: 7.38 GiB (3.4%) fs: ext4 dev: /dev/sda1 label: INLINUX 
           uuid: eb47f141-6504-49a0-b852-609a6bce2587 
Swap:      ID-1: swap-1 type: partition size: 8.80 GiB used: 698.6 MiB (7.8%) priority: -2 dev: /dev/sdb3 label: N/A 
           uuid: f88d7276-0adc-4150-9dec-98be8bba9831 
Unmounted: Message: No unmounted partitions found. 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-4:2 info: China Resource Semico USB Keyboard type: Keyboard,Mouse driver: hid-generic,usbhid 
           interfaces: 2 rev: 1.1 speed: 1.5 Mb/s chip ID: 1a2c:2d43 
           Device-2: 1-6:3 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid 
           interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 046d:c52b 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 43 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 276 Uptime: 4h 33m Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1344 pacman: 1335 
           snap: 9 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

I’ve also searched similar topics on the Archived forum but can’t find anything
I’ve tried to upload the screenshot. But seems This forum won’t let me incl a Link

Welcome to the forum! :slight_smile:

There’s your problem, right there. But since you’re new to GNU/Linux, you probably don’t know this…

When it comes to graphical applications and desktop environments (or window managers), the two main widget toolkits used for writing the applications and desktop environments are Qt and GTK. Qt is incredibly flexible and customizable ─ GTK not so much, and it doesn’t have a good history of working together with Qt/KDE either.

Now, KDE Plasma is a desktop environment based upon the Qt libraries. Vivaldi is a browser based upon GTK.

Now, Firefox is also a GTK-based browser, but Firefox can be coaxed to work together with Qt, and so you can tell Firefox to use the KDE-native file open/save dialog instead of its own GTK-based dialog. Chromium, which is also a GTK-based browser, even does it without giving you any trouble at all.

However ─ and here’s the catch ─ to the best of my knowledge, Vivaldi does not support this, and being a GTK application, it will thus use the GTK-native file open/save dialog, which does not support thumbnails.


That is correct. New users are only allowed a subset of the forum’s functionality ─ this is a property of the Discourse forum engine, and it is primarily so as to protect the community against spammers and bots.

As your post count increases, you will eventually reach a higher trust level and more functionality will become available to you. :wink:


On my testing and unstable branch installs, Vivaldi is using the KDialog for saving and opening files. You enable it where the arrow points …

Not sure if this is something that changed in the latest updates, i do recall Vivaldi being a bit rebel regardless if i was or not using the export GTK_USE_PORTAL=1 or export GTK_USE_PORTAL=0 in /etc/xdg/plasma-workspace/env/envars.sh
Now none of those is present in that file …


Thank you.
That solved the problem.
I’ve followed this tutorial on reddit

  • Make sure you have the xdg-desktop-portal and xdg-desktop-portal-kde packages installed.
  • Right click the Firefox launcher in the app launcher > Edit Application
  • Application tab > Command GTK_USE_PORTAL=1 /usr/lib/firefox/firefox %u

But I was really got used to the side panel of Vivaldi and split-screen tile tab stack functionality. was really helpful for freelancers like me.
I think there is no other way to do it on the Chromium-based browser.

One more question :
Is it possible to enable Thumbnail view on Gnome desktop for Chromium-based browsers? I mean Use Nautilus as a File picker?
( I don’t mind to switch to Manjaro Gnome If this is possible )

No, not that I know of. GNOME is entirely GTK-based and quite locked-down.

Do however note that Chromium proper ─ which is in the repository ─ does use the kdialog natively, or at least, in Plasma, with those packages installed. :wink:

1 Like

I think I will go for Chromium . Thank you for all the help :pray:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.