Abhängigkeiten: Und nun:

Liebe Freunde,

was ist jetzt zu tun, um die 481 neuen Pakete zu installieren?

:: Starting full system upgrade…
:: Replace kdsoap with extra/kdsoap-qt5? [Y/n] y
:: Replace kirigami-addons with extra/kirigami-addons5? [Y/n] y
warning: kpeoplevcard: local (0.1+r38.32d50a9-1) is newer than extra (0.1-2)
:: Replace kuserfeedback with extra/kuserfeedback5? [Y/n] y
:: Replace libkcddb with extra/libkcddb5? [Y/n] y
:: Replace libqaccessibilityclient with extra/libqaccessibilityclient-qt5? [Y/n] y
warning: sndio: local (20180120-1) is newer than extra (1.9.0-1)
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing kholidays5 (1:5.112.0-1) breaks dependency ‘kholidays’ required by kalarmcal
:: installing ki18n5 (5.112.0-1) breaks dependency ‘ki18n’ required by kjsembed
:: installing kpeople5 (5.112.0-1) breaks dependency ‘kpeople’ required by kpeoplevcard
:: installing kcontacts5 (5.112.0-1) breaks dependency ‘kcontacts’ required by kpeoplevcard
:: installing kxmlgui5 (5.112.0-1) breaks dependency ‘kxmlgui’ required by libkipi
:: installing kservice5 (5.112.0-1) breaks dependency ‘kservice’ required by libkipi
PAKtC

Grüße Jan

sudo pacman-mirrors -c Germany 
sudo pacman -Scc 
sudo pacman -Syu
pamac update -a --force-refresh

Hallo,
das läst das Problem nicht. Nach dem dritten Befehl erschien die gleiche Fehlerliste wie in meinem ersten Posting. Nach dem vierten Befehl wurden die Datenbanken aktualisiert. Nach einer Weile erschien dann folgendes Ergebnis:

arnung: das Installieren von kholidays5 (1:5.112.0-1) verletzt Abhängigkeit ‘kholidays’ benötigt von kalarmcal
Füge kalarmcal hinzu, um zu entfernen
Warnung: das Installieren von ki18n5 (5.112.0-1) verletzt Abhängigkeit ‘ki18n’ benötigt von kjsembed
Füge kjsembed hinzu, um zu entfernen
Warnung: das Installieren von kpeople5 (5.112.0-1) verletzt Abhängigkeit ‘kpeople’ benötigt von kpeoplevcard
Füge kpeoplevcard hinzu, um zu entfernen
Warnung: das Installieren von kcontacts5 (5.112.0-1) verletzt Abhängigkeit ‘kcontacts’ benötigt von kpeoplevcard
Füge kpeoplevcard hinzu, um zu entfernen
Fehler: Vorgang konnte nicht erfolgreich vorbereitet werden:
Kann Abhängigkeiten nicht erfüllen:

  • nicht vorhandene Abhängigkeit ‘kxmlgui’ benötigt von libkipi
  • nicht vorhandene Abhängigkeit ‘kservice’ benötigt von libkipi
    Warnung: kpeoplevcard: Lokale Version (0.1+r38.32d50a9-1) ist neuer als extra (0.1-2)
    Warnung: sndio: Lokale Version (20180120-1) ist neuer als extra (1.9.0-1)
    Abhängigkeiten werden aufgelöst…
    Interne Konflikte werden überprüft…
    Fehler: Vorgang konnte nicht erfolgreich vorbereitet werden:
    Kann Abhängigkeiten nicht erfüllen:
  • nicht vorhandene Abhängigkeit ‘kxmlgui’ benötigt von libkipi
  • nicht vorhandene Abhängigkeit ‘kservice’ benötigt von libkipi

Build-Dateien bearbeiten : [e]
Transaktion anwenden ? [e/j/N] j

Vorgang abgebrochen.

Bitte die Fehlermeldung mal richtig durchlesen!

Deinstalliere die Programme, die dass Update verhindern und installiere sie später bei Bedarf wieder.

sudo pacman -R kalarmcal kjsembed kpeoplevcard libkipi

Danach sollte ein update durchlaufen…

Vielen lieben Dank.

daran hatte ich ebenfalls bereits gedacht. Ich möchte lediglich vermeiden, danach vor einem schwarzen Bildschirm zu sitzen. Handelt es sich um nette, aber letzlich irrelevante Bausteine?

Herzlich

Jan

Um dies zu überprüfen, kannst Du folgendes auf der Konsole ausführen: pacman -Rs $(pacman -Qtdq).

Wenn du so unsicher bist, dann mach doch vorher ein snapshot mit timeshift und sichere dich damit ab.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.