A trouble with system update

I am still a newbie in terms of packages and these stuff. Today when I booted my PC I got notification says that about 360 packages has an update as usual but when I decided to update I found a problem.
It is something with Pulseaudio being removed and that would break dependency with other packages, GUI says a little stuff but when I tried to do in terminal I got more information.
Basically pipewire-pulse is in conflict with pulseaudio, pulseaudio-bluetooth and manjaro-pulse but removing this will break dependency of pulseaudio=16.1-1 for these packages: pulseaudio-equalizer, pulseaudio-jack, pulseaudio-jack, pulseaudio-rtp and pulseaudio-zeroconf.

Is it safe to remove these packages or should I do something else? I am really not expirienced in these Pulseaudio Pipewire stuff so I have no idea what is going on and why now.

Maybe post the exact messages you get so we may see on how to help you. pipewire-pulse is in conflict, yes. Now we have to figure out why a package might depend on that one.

The thing is, my system is in Polish language and I don’t know how to change the language of terminal to English. Changing language in System Settings only changed language in GUIs but terminal stays in Polish.
I know it is kinda embarrassing…

If you run it it terminal, simply prepend your command with LANG=C

E.g. LANG=C pamac upgrade

As for your questions, you can safely remove the few conflicting packages you listed, they are not needed for a common/usual setup.

If you need them with your special sound setup, you can reinstall them after the update again.

Thank you, didn’t know it was that simple! :slight_smile:
I also usual use Pacman instead of Pamac. Is there any negatives?

And this is what I see when I try to update:

LANG=C sudo pacman -Syu                                                                                                                                                                           
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: pipewire-pulse and pulseaudio are in conflict. Remove pulseaudio? [y/N] y
:: pipewire-pulse and pulseaudio-bluetooth are in conflict. Remove pulseaudio-bluetooth? [y/N] y
:: pipewire-pulse and manjaro-pulse are in conflict. Remove manjaro-pulse? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pulseaudio breaks dependency 'pulseaudio=16.1-1' required by pulseaudio-equalizer
:: removing pulseaudio breaks dependency 'pulseaudio=16.1-1' required by pulseaudio-jack
:: removing pulseaudio breaks dependency 'pulseaudio=16.1-1' required by pulseaudio-lirc
:: removing pulseaudio breaks dependency 'pulseaudio=16.1-1' required by pulseaudio-rtp
:: removing pulseaudio breaks dependency 'pulseaudio=16.1-1' required by pulseaudio-zeroconf

GUI shows similar thing but lists only first broken dependency.

From my experience pamac has a better dependency management than pacman.

First, I would recommend updating your mirrors, just in case: sudo pacman-mirrors --continent --method rank

And then try the update again: pamac update --force-refresh
(it might already help).

If it doesn’t help, you can remove these packages:
pamac remove pulseaudio-{equalizer,jack,lirc,rtp,zeroconf}

and then retry the update.

As you are a noobie, I’m afraid of asking, but is there are reason you’re using pulseaudio rather than pipewire? If not, then you could also replace pulseaudio with pipewire:
pamac install manjaro-pipewire


I never changed anything in terms of audio stuff. When I installed Manjaro at the end of previous year it had Pulseaudio and Pipewire installed at the same time. All I know is that some programs want Pulseaudio like Pavucontroll and some want Pipewire like Helvum but this is where my knowledge ends. All I tried was trying to enable DTS but it didn’t went well so I gave up.

If I would want to have just Pipewire, would I need to do some additional configuration? I don’t have much time today so I need to organize some stuff if that’s the case.

I don’t know those programs you mentioned. In general, there is no difference and apparently pipewire is the future. So you could try it at least.

Alright I just installed manjaro-pipewire and removed residual Pulseaudio packages and now everything work under Pipewire. Thanks for help! :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.