A multitude of problems

So while the title is rather unhelpful I’ve encountered too many issues to sum it up with a one liner lest I open 40 topics at once. I’ll start with the biggest issues though.

#1 Has been reported a few times on here with no real fix. The installer fires up and just seems to hang with waiting on module. I later tried with the -d flag and behind the scenes it’s just spitting out

Remaining modules: 1

I’ve tried a few times and some times it hangs indefinitely (over 10minutes before I just rebooted) other times 4 or 5 minutes it will finally move on.

The one time it moved on it hung almost at every step for several minutes each step. Often times with no feed back if a click was accepted.

This also turned into hangs when trying to select disk options with a small modal dialog that hung. Upon just closing it it moved on like the progress of the dialog was irrelevant to the process of installing.

#2 Has also been reported but none of the fixes worked for me. Once / IF you can get it installed it won’t boot. The only way to do anything is if you select the initramfs fallback. I rebuilt initramfs, reinstalled grub, nada, same same, no dice.

#3 This one I didn’t find any reports on but it really has me cockeyed. Once I got things semi working with the initramfs option I tried to test a few other things. The #1 thing was to test what the system does with more than one XScreen as this breaks every distro/DE I’ve tried in the last few years. I set up my XScreens with the nvidia-driver panel, restarted X…it loads exactly as it was. I checked and checked that my config was correctly saved to /etc/X11/xorg.conf…checked the logs which say THAT IS the config in use…yet none of the changes are adhered to. One XScreen despite the config having 3.

This is not an exhaustive list of issues I found on this initial impression of Manjaro but it sure is a headscratcher and showstopper.

One last thing to note is I tried during the install attempts to update the system before installing incase a fix was rolled out but it never helped with any of these issues. Also once installed I’d get messages about updates and specifically a newer kernel and to please update. I’d go to check updates and be told everything was up to date…say wha?

1 Like

Which ISO?
Did you verify integrity?
How was it written to your media?

If we cant be sure of the installation in the first place (such as failed install and partial recovery)… then all issues could be assumed to be related to that.


manjaro-xfce-21.1.6-minimal-211017-linux513.iso sha1sum checks out. Wrote drive with balena-etcher (set to verify writes). I should also note that testing the iso with a VM things went real nice. Bare metal though…not so much.