A little Smb4k coaching might save me from a big Timeshift mistake

After many failures I finally got Smb4k to mount Windows shares. In htop I noticed Smb4k was running as me and that’s when the 5-watt bulb in my brain flickered. Also, there’s nothing in the docs about ownership and permissions when the mount directory is outside the user’s /home, which further suggests that Smb4k is designed for the user owning the whole enchilada.

As recommended, I started out with /mnt/smb4k for the mount directory. But root ownership was a problem. After creating /home/me/smb4k (as me) and resetting Smb4k back to its defaults, mounting worked straight away. Then I changed ownership for /mnt/smb4k –

sudo chown -R me:me smb4k

and changed the mount prefix in Smb4k back to /mnt/smb4k and it continued to mount. Problem solved.

However, one advantage of using Smb4k’s default mount prefix starting in /home is that Timeshift excludes it by default. How can I exclude /mnt/smb4k from Timeshift Btrfs? Until I’m able to do that I think I’m safer with /home/me/smb4k.

Edit: It just occurred to me that /mnt isn’t a Btrfs ‘@’ namespace so does this mean Timeshift ignores it?

Isn’t there an extra tab in Timeshift to add an exclude filter? Meaning you would add /mnt/*** to the filter list?

Looks like it’s different when using the Btrfs snapshot method. Technically, /mnt (and other partitions/volumes) naturally live outside of your Btrfs tree, so I would think they are ignored by default.

Yeah, your user needs to own the folder to be able to create subdirectories within.

Get used to using Smb4K’s main window, rather than the tray icon. The tray icon occasionally has weirdness going on, which the developer is currently working on some fixes. Worst-case scenario, you can still use “sudo umount /mnt/smb4k/blah/blah” to unmount a share after exiting the program.

I mostly keep Smb4K hidden in the tray, and restore the window when I want to mount, unmount, explore a share, access a bookmark, etc.

There’s a handful of useful options that might not be as obvious at first glance. Right-click on any option or checkbox → and click “What’s this?”


I noticed a Timeshift filter button for an ext4 installation. For Btrfs I’ll try a light-weight temporary share to see if /mnt/smb4k shows up in the Timeshift log.

I see what you meant about Smb4k streamlining the process. As long as I remember to unmount before shutting down I think I’m good to go. Thanks again!