9560 Bumblee stopped working?

I used to disable (and enable) the dGPU with bumblebee on the Dell XPS 9560.

Now, when I cat /proc/acpi/bbswitch, I get
0000:01:00.0 OFF

But, in powertop, it seems to be burning the Wattage indicating it’s actually ON.

And, interestingly, when I sudo dmesg | grep bbswitch, I get
[1145227.355306] bbswitch: enabling discrete graphics

bumblebeed is enabled in systemctl, acpi_override=1, etc. Am I going crazy, or did something in this chain break?

You could try the prime-offload method instead

See that entire wiki, is for your laptop model. Maybe there are more things you can make use of.

That literally says you can’t disable the dGPU.

Power consumption is much higher during light usage because the discrete GPU cannot be disabled.

Why anyone would use that is beyond me.

But, in powertop, it seems to be burning the Wattage indicating it’s actually ON.

Oddly, regressing the kernel to an ancient one re-enabled bumblee ability to turn off dGPU.

But, if you use Optimus-Manager you can have 3 options
See here:

Kernel 5.4 is not ancient. Is LTS

1 Like

Optimus-manager doesn’t/can’t turn off the dGPU. I tried it. It’s a known issue with the 9560 that it’s very stubborn about turning off the dGPU. Please don’t recommend it to any 9560 users.

I think 4.9 is the kernel that worked. It is both ancient and LTS.

Is one thing that one particular GPU has that behavior, and is another to say “Optimus-manager doesn’t/can’t turn off the dGPU” - that implies is not working for any GPU … so, yeah.

ancient has nothing derogatory attached to it, if that is what you imply.

4.19 LTS was last patched on 2020-09-03 at the time of this writing and the reason why Manjaro supports multiple kernels. Bumblebee is in the same situation anyway: it receives patches but no new development.

If the 4.19 kernel solves your Bumblebee issue then that’s the solution…


P.S. Most people think that the latest new kernel is what you need all of the time but this is not true: You only need a new kernel if your new hardware is not supported by an older LTS kernel.


I needed 5.7/5.8 for a key feature. Sadly, these kernels break bumblebee and triple-click as middle-click functionality in Manjaro, which are pretty important on this particular laptop and my use thereof.

Topic cleaned. No fighting, no biting.