(940mx + intel ) Nonfree driver issue ! Looking for helps :(

inxi -Fx
 System:
   Host: Yaman-Pc Kernel: 4.14.48-2-MANJARO x86_64 bits: 64 compiler: gcc 
   v: 8.1.1 Desktop: Gnome 3.28.2 Distro: Manjaro Linux 17.1.10 Hakoila 
 Machine:
   Type: Laptop System: Micro-Star product: CX62 6QD v: REV:1.0 
   serial: <root required 
   Mobo: Micro-Star model: MS-16J6 v: REV:1.0 serial: <root required 
   UEFI: American Megatrends v: E16J6IMS.10C date: 01/17/2018 
 Battery:
   ID-1: BAT1 charge: 40.7 Wh condition: 41.4/42.4 Wh (98%) 
   model: MSI Corp. MS-16J6 status: Unknown 
 CPU:
   Topology: Quad Core model: Intel Core i5-6300HQ bits: 64 type: MCP 
   arch: Skylake-S rev: 3 L2 cache: 6144 KiB 
   flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18436 
   Speed: 899 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 900 2: 898 
   3: 900 4: 900 
 Graphics:
   Card-1: Intel HD Graphics 530 driver: i915 v: kernel bus ID: 00:02.0 
   Card-2: NVIDIA GM108M [GeForce 940MX] driver: nouveau v: kernel 
   bus ID: 01:00.0 
   Display: x11 server: N/A driver: nouveau resolution: <xdpyinfo missing 
   OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) 
   v: 4.5 Mesa 18.1.1 direct render: Yes 
 Audio:
   Card-1: Intel Sunrise Point-H HD Audio driver: snd_hda_intel v: kernel 
   bus ID: 00:1f.3 
   Sound Server: ALSA v: k4.14.48-2-MANJARO 
 Network:
   Card-1: Intel Wireless 3165 driver: iwlwifi v: kernel bus ID: 02:00.0 
   IF: wlp2s0 state: up mac: 68:07:15:10:c9:67 
   Card-2: Qualcomm Atheros QCA8171 Gigabit Ethernet driver: alx v: kernel 
   port: d000 bus ID: 03:00.0 
   IF: enp3s0 state: down mac: d8:cb:8a:f5:99:9a 
 Drives:
   HDD Total Size: 931.51 GiB used: 8.55 GiB (0.9%) 
   ID-1: /dev/sda vendor: Hitachi model: HGST HTS721010A9E630 
   size: 931.51 GiB 
 Partition:
   ID-1: / size: 33.95 GiB used: 6.38 GiB (18.8%) fs: ext4 dev: /dev/sda1 
   ID-2: /home size: 238.75 GiB used: 2.16 GiB (0.9%) fs: ext4 dev: /dev/sda2 
   ID-3: swap-1 size: 5.95 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
 Sensors:
   System Temperatures: cpu: 51.0 C mobo: 27.8 C 
   Fan Speeds (RPM): N/A 
 Info:
   Processes: 200 Uptime: 31m Memory: 7.71 GiB used: 2.83 GiB (36.8%) 
   Init: systemd Compilers: gcc: N/A Shell: bash v: 4.4.19 inxi: 3.0.10

mhwd -l

 0000:00:02.0 (0300:8086:191b) Display controller Intel Corporation:
 --------------------------------------------------------------------------------
                   NAME               VERSION          FREEDRIVER           TYPE
 --------------------------------------------------------------------------------
 video-hybrid-intel-nvidia-bumblebee            2018.05.04               false            PCI
 video-hybrid-intel-nvidia-390xx-bumblebee            2018.05.04               false            PCI
            video-linux            2018.05.04                true            PCI
             video-vesa            2017.03.12                true            PCI
 
 
 0000:01:00.0 (0302:10de:134d) Display controller nVidia Corporation:
 --------------------------------------------------------------------------------
                   NAME               VERSION          FREEDRIVER           TYPE
 --------------------------------------------------------------------------------
 video-hybrid-intel-nvidia-bumblebee            2018.05.04               false            PCI
 video-hybrid-intel-nvidia-390xx-bumblebee            2018.05.04               false            PCI
           video-nvidia            2018.05.04               false            PCI
     video-nvidia-390xx            2018.05.04               false            PCI
            video-linux            2018.05.04                true            PCI

xrandr --listproviders

 Providers: number : 2
 Provider 0: id: 0x88 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 5 associated providers: 1 name:Intel
 Provider 1: id: 0x5f cap: 0x5, Source Output, Source Offload crtcs: 0 outputs: 0 associated providers: 1 name:nouveau

Now I have trying to install nvidia , bumblebee driver for a week… I formated too much…

Im tried all of ways I think but after installed bumblebee after reboot pc is gonna freeze and I cant go in tty…

I tried blacklist noueveu it isnt worked too…

I cant use bios to change gpu cuz its locked bios…

Please help me about it ! Im stuck very badly…
I was using ubuntu with prime nvidia but in manjaro I cant handle the setup think

Im waiting for support…

Edit: Im looking for use nonfree drivers. No matter prime, bumblebeed

When I try to boot with nonfree drivers from live media its stuck at:
" Started TLP system startup/shutdown "

And When opening gdm, taking errors like this

Have you tried this Guide?

Im going to try this ! Thanks for this guide but I have no hope so I will give info at the end

1 Like

I cant understand 3.1 part. How can I remove and replace with it ? there is no write in optimus.conf

You don’t have this (you run the default settings) so just create a new file and edit as advised (hidden info? you missed it?)

remove /etc/X11/xorg.conf.d/90-mhwd.conf

1 Like

No sorry its my mistake. I mean how can I replace it.

Paste this into a file and save the file as /etc/X11/xorg.conf.d/optimus.conf :

Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "AllowEmptyInitialConfiguration"
EndSection

It needs sudo rights (sudo gedit in terminal)

I have done all of the guide…

And thats pufff its magicaly done :smile:

I was tried this before but I missed somethink I think… Thanks for everythink you have saved my life my friend…

2 Likes

You should thank the Tutorial author. I just pointed, not a big thing :smirk:
I hope sometime, Manjaro users will look up first at Manjaro Tutorials. :joy:

The big problem is there is too many tutorial about this and each one is diffrend so not new user friendly… We need a topic with list of (working) tutorials…

There is already one (kind-of) but is WIP. Actually it’s pinned at the top of Tutorials category.

1 Like

I have done UEFI install by myself… There is no any guide to solved my problem :smile:
But thanks again I will research all of this guides now :eyeglasses:

After using PRIME : Really high performance on games but there is really low battery life and really highy temps… So I tried to install bumblebeed service, now everythink is okey :slight_smile:

I really suggest Bumblebee Drivers :lollipop:

This is the price to “pay” for performance :wink:

Whatever works is good!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark