5.8.11-1-MANJARO unable to suspend PC, 4 tasks refusing

Hello, pm suspend failed and the “dmesg” shows:

Freezing of tasks failed after 20.000 seconds (4 tasks refusing to freeze, wq_busy=0):

When i lookup that dmesg output, and search for “Freezing of tasks failed” then i find several places and the line below each seems to be certain process name and the number is likely the PID. So the cause is mount.ntfs and the veracrypt which is used to mount the volume with the ntfs filesystem. Can i work around this without having to close all apps using this volume and dismounting it before each suspend? Or is there something to be done to fix this and make it suspend?

Hello,

You have amule there too. It was downloading on the NTFS volume?

Inside /etc/pm/sleep.d/ you could place a script like this:

#!/bin/sh
(killall -9 mount.ntfs; exit 0)

but nouveau driver is known to create some issues too on laptops with Nvidia GPU’s, and that pops too in the log.

inxi -Fazy
from terminal might help identify more about that system, plus
mhwd -li

1 Like

IMHO, like @bogdancovaciu pointed out above, is that the real cause is actually amule which in turn seems to use transmission-gt which uses the NTFS on veracrypt.
So my personal advice would be to find some way to stop amule just before the suspend to start with :wink:

1 Like

It happen again, and i do not see any processes preventing it. dmesg:

[615763.341370] PM: suspend entry (deep)
[615763.566835] Filesystems sync: 0.225 seconds
[615763.567968] Freezing user space processes ... (elapsed 0.004 seconds) done.
[615763.572640] OOM killer disabled.
[615763.572641] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[615763.574307] printk: Suspending console(s) (use no_console_suspend to debug)
[615763.591625] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[615763.592420] sd 0:0:0:0: [sda] Stopping disk
[615763.671650] nouveau 0000:04:00.0: Enabling HDA controller

The reason is likely that suspend is ok, but some device awake it immediately?

    [616409.780689] ACPI: Preparing to enter system sleep state S3
[616409.782366] ACPI: EC: event blocked
[616409.782366] ACPI: EC: EC stopped
[616409.782367] PM: Saving platform NVS memory
[616409.782378] Disabling non-boot CPUs ...
[616409.783767] smpboot: CPU 1 is now offline
[616409.786049] smpboot: CPU 2 is now offline
[616409.787956] smpboot: CPU 3 is now offline
[616409.789222] ACPI: Low-level resume complete
[616409.789291] ACPI: EC: EC started
[616409.789292] PM: Restoring platform NVS memory
[616409.792969] Enabling non-boot CPUs ...
[616409.793264] x86: Booting SMP configuration:
[616409.793265] smpboot: Booting Node 0 Processor 1 APIC 0x1
[616409.794380] CPU1 is up
[616409.794680] smpboot: Booting Node 0 Processor 2 APIC 0x2
[616409.797759] CPU2 is up
[616409.798047] smpboot: Booting Node 0 Processor 3 APIC 0x3
[616409.799016] CPU3 is up
[616409.800679] ACPI: Waking up from system sleep state S3
[616409.804716] ACPI: EC: interrupt unblocked
[616409.915033] ACPI: EC: event unblocked
[616409.925287] sd 0:0:0:0: [sda] Starting disk

When i used “sudo powertop” and disabled USB wake for numerous devices, it is suspending OK. Yet i do not understand why i do not see this USB wake event in dmesg.