5.15.19-1 isn't EOL, is it?

Hey guys.
I’m getting dependency issues when trying to update through Octopi or pacman -Syyu

:: removing linux510-rt-headers breaks dependency 'linux510-rt-headers' required by linux-rt-lts-manjaro-headers  
:: installing nvidia-utils (510.47.03-4) breaks dependency 'nvidia-utils=495.46' required by linux514-nvidia

I’m unsure as to the importance of rt-lts-manjaro-headers, and sadly can’t find much info on them that makes sense to me, so I’d like to double check with you.
When trying to switch to 5.16.5-1 (currently on 5.15.19 as in the title), as seems to be the most suggested fix, there are additional dependency troubles. Announcements still seem to list 5.15.19 as supported (though it’s a bit hard to find the correct place to look Kernel status up)

:: installing nvidia-utils (510.47.03-4) breaks dependency 'nvidia-utils=495.46' required by linux419-nvidia
:: installing nvidia-utils (510.47.03-4) breaks dependency 'nvidia-utils=495.46' required by linux510-nvidia
:: installing nvidia-utils (510.47.03-4) breaks dependency 'nvidia-utils=495.46' required by linux514-nvidia
:: installing nvidia-utils (510.47.03-4) breaks dependency 'nvidia-utils=495.46' required by linux515-nvidia
:: installing nvidia-utils (510.47.03-4) breaks dependency 'nvidia-utils=495.46' required by linux515-rt-nvidia
:: installing nvidia-utils (510.47.03-4) breaks dependency 'nvidia-utils=495.46' required by linux54-nvidia

am I correct in thinking this might be because I have some older Kernels as fallbacks still installed?
(4.19.227-1, 5.4.176-1, 5.14.21-2, 5.15.18_rt28-2)
Thank you.

5.14 is EOL. Remove the nvidia driver first and then try to update.

sudo pacman -Rdd linux-rt-lts-manjaro-headers linux514-nvidia
sudo pacman -Syu
1 Like

Ohh, I hadn’t realized that non-running EOL kernels influenced update behaviour.
Thank you very much!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.