5.10.70 crashing (actually freezing everything)

I recently installed Manjaro on this laptop. The Manjaro iso used: 5.13 which is now eol.

I tried to switch to 5.10.70 and after a few minutes, everything freezed. No keyboard… The only thing that kind of worked was the mouse. I could move it but not click on anything.

This is the only thing I could see on the journal:

Oct 16 18:36:35 dodoite kernel: INFO: task kworker/5:1:72 blocked for more than 122 seconds.
Oct 16 18:36:35 dodoite kernel:       Not tainted 5.10.70-1-MANJARO #1
Oct 16 18:36:35 dodoite kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Oct 16 18:36:35 dodoite kernel: INFO: task kworker/5:3:488 blocked for more than 122 seconds.
Oct 16 18:36:35 dodoite kernel:       Not tainted 5.10.70-1-MANJARO #1
Oct 16 18:36:35 dodoite kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Oct 16 18:37:02 dodoite systemd-coredump[2332]: Failed to connect to coredump service: Connection refused

It doesn’t say which task… No idea.

I’m back on 5.13.19. No problem, so far “rock solid”…

Any suggestion on what to do at this point.

Here’s my inxi

$ inxi -Fxxxz
System:    Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
           dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Convertible System: LENOVO product: 81X2 v: IdeaPad Flex 5 14ARE05
           serial: <filter> Chassis: type: 31 v: IdeaPad Flex 5 14ARE05 serial: <filter>
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO
           v: EECN36WW date: 05/17/2021
Battery:   ID-1: BAT0 charge: 31.6 Wh (60.2%) condition: 52.5/52.5 Wh (100.0%) volts: 11.1
           min: 11.5 model: Celxpert L19C3PD6 type: Li-poly serial: <filter> status: Unknown
           cycles: 1
CPU:       Info: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP
           arch: Zen 2 rev: 1 cache: L2: 4 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
           bogomips: 31959
           Speed: 3533 MHz min/max: 1400/2000 MHz boost: enabled Core speeds (MHz): 1: 3533
           2: 3624 3: 2689 4: 1697 5: 3670 6: 1944 7: 2305 8: 1397
Graphics:  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 04:00.0
           chip-ID: 1002:1636 class-ID: 0300
           Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 1-4:3
           chip-ID: 174f:243f class-ID: 0e02 serial: <filter>
           Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver:
           loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
           resolution: 2560x1080~60Hz s-dpi: 96
           OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.19-2-MANJARO LLVM 12.0.1)
           v: 4.6 Mesa 21.2.3 direct render: Yes
Audio:     Device-1: AMD driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:1637
           class-ID: 0403
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo
           driver: N/A bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
           Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
           bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: no
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo
           driver: rtw_8822ce v: N/A port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:c822
           class-ID: 0280
           IF: wlp2s0 state: down mac: <filter>
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
           bus-ID: 2-1.4:4 chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
           IF: enp4s0f3u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-4:3
           chip-ID: 0bda:c123 class-ID: e001 serial: <filter>
           Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: N/A rfk-block:
           hardware: no software: yes address: see --recommends
Drives:    Local Storage: total: 476.94 GiB used: 78.67 GiB (16.5%)
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000L2 size: 476.94 GiB
           speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 3L1QEXF7 temp: 28.9 C
           scheme: GPT
Partition: ID-1: / size: 459.43 GiB used: 78.67 GiB (17.1%) fs: ext4 dev: /dev/nvme0n1p2
           ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
Swap:      ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
           dev: /dev/nvme0n1p3
Sensors:   System Temperatures: cpu: 48.8 C mobo: 36.0 C gpu: amdgpu temp: 39.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 228 Uptime: 25m wakeups: 29 Memory: 15.01 GiB used: 2.31 GiB (15.4%)
           Init: systemd v: 249 Compilers: gcc: 11.1.0 Packages: pacman: 1242 Shell: Bash
           v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.07

If I’m right, your machine is pretty recent?

A more recent kernel could be better, as newer hardware are better supported with newer kernels.
Could you try 5.14 kernel and check how your system behaves?

If you absoluterly want 5.10 as it’s LTS, more issue digging will be necessary.

I bought the laptop at costco in the spring 2021, but the amd CPU + APU came in late 2019.

Right now, I’m using manjaro/5.14 and it’s currently working, but I’d be more comfortable with an LTS.

I tested my laptop with a live debian 11 bullseye and it uses: 5.10.70. It works w/o any problem. I assume that it either has to do with either a Manjaro configuration or a Manjaro firmware.

Debian backports features and bugfixes from newer kernels, but Manjaro use vanilla kernel, mostly.