2nd hdd stops boot

The error
[Failed] Failed to mount /run/media/garlo
[Depend] Dependency failed for Local File Systems
You are in emergency mode. After logging in, type “journalctl -xb” to view system logs, “systemctl reboot” to reboot, “systemctl default” or “exit” to boot into default mode.
Root password for maintenance (or press Control-D to continue):

I was trying to make the 2nd hdd usable

Sometime later I updated the system & restarted
The operating system & home are on nvme(0), the secondary is sda
I could see sda as a device in dolphin, a folder lost&found that was locked
I messed up the mount point using KDE partition manager, as I struggle with bash
Removing sda did not help :smiley:

I found this thread

I don’t know how to navigate emergency mode to vi /etc/fstab to add a # so it will ignore sda at boot

You can boot into a live ISO, mount the root filesystem (or use manjaro-chroot), make the changes in fstab, and then reboot.

You don’t have to comment out the /etc/fstab entry for that volume. All you need to do is add nofail to its mount options, like so… :arrow_down:

UUID=some-long-string /run/media/garlo  ext4  defaults,noatime,nofail  0  0

You can boot up from the installer USB/CD/DVD in live mode, mount your root filesystem from there and then edit its fstab. You don’t even need to chroot for doing that. For instance… :arrow_down:

sudo su -
mkdir /mnt
mount -t ext4 /dev/nvme-whatever-other-characters /mnt
cd /mnt/etc
nano fstab
1 Like

Doing it through a live version is just another layer of complication
None of that gets me to fstab, this machine is almost identical, I can’t open dolphin>show hidden files & navigate to fstab?
I’m not seeing /ect anything, so I can’t write the path to it on the broken machine
Doing it through a live version isn’t a solution to my problem

Since it is the emergency mode, I guess / is read-only. Therefore you need to remount it:

mount -n -o remount,rw /

Then just type:

nano /etc/fstab

comment out the line and run:

systemctl default

Also, /run exists only in memory. So on every boot the folder media and garlo needs to be recreated. Normally done by the file manager, after everything has been started. So therefore the error here is related to a non-existing folder.

If you need to add it to /etc/fstab, then create the folder here: /media/myhdd and mount it there.