2nd HDD Not Mounting on Startup

I am new to Manjaro, just installed yesterday on former Ubuntu setup.

Could someone please help me with correcting for my second HDD not mounting on startup?

I can mount and access this drive from Files without issue.

I have read many related posts but unfortunately have limited understanding of fstab etc.

“Mount at system startup” is checked in Disks mount options, but mount point is listed incorrectly there as:

Output of df in terminal shows:
/dev/sdb1 917G 235G 636G 27% /run/media/rosie/HDD2

Is there a simple fix?

Hi @baum, and welcome!

Please see [root tip] Use systemd to mount ANY device

Hope it helps!

Am working my way through the article you linked but am missing something.

I created a file named hdd2.mount and placed it in /etc/systemd/system

Contents of the file:

Description=Mount HDD2



When I try to mount the device:
sudo systemctl start hdd2.mount

I get:
Failed to start hdd2.mount: Unit hdd2.mount has a bad unit file setting.
See system logs and ‘systemctl status hdd2.mount’ for details.

In Disks, the mount point should be /mnt/HDD2. Set Identify As to LABEL=HDD2.


Yochanan, that was the simple solution that worked, thank you!

I had to leave User Session Defaults toggled off for these settings to stick.


1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.