2FA Support For Pinephone

On my Pinephone I can’t use the Authenticator app to add a new 2FA token. When I click the “+” button to open the camera to scan the code nothing happens. There is no error message. The Megapixels app is able to use the camera to take pictures so the camera works. This is not a specific Manjaro Arm issue as it happens on various distros I tried.

I tried to raise the issue on the Gitlab of the Authenticator team but got the response of “there’s no support for pinephone’s camera nor there would be. unless it’s fixed somewhere between the kernel & gstreamer and it works out of the box. Any effort has other than this must be done by interested parties: aka people that use a pinephone”.

Have any Pinephone users been able to get 2FA setup on it ? If so what distro; desktop environment and app did you use ? I have had zero success on Mobian; Ubuntu Touch; Manjaro Arm and PostmarketOS.

1 Like

I too would like this feature to work, it is a requirement for my phone to have a functional google auth.

1 Like