2FA fails for end users - please consider enabling Automatic Date & Time by default

As I help a few elderly people with their PCs/laptops, I sometimes get the same issue from all of them and even from my own family or kids:
2FA no longer works. Could be an issue with the service you are trying to login to, the sign on page or perhaps the authenticator app. You could go in all directions. However in each case it drilled down to a small deviation in time: the system time was behind almost a minute.

For 2FA to work it is important the laptop/pc has the same time as the server of your bank or whatever type of account you want to login to. Since 2FA is becoming popular and is being pushed by most webservices, more people will require correct system time.

I would like to make the case it might be useful to enable Automatic Time & Date (not to be confused with Automatic Timezone) by default as it seems like a sane, basic option that most end users will have to enable anyway.

I think it is default - but you could check the service

systemctl status systemd-timesyncd

Yes it is enabled now that I enabled it in Settings. But after installing Manjaro, it is disabled, it is off by default and you have to enable it via Settings > Date & Time (or systemctl). This is fine but most users won’t even know it is disabled, until they are faced with an issue like 2FA failing and then still most users will not realize it is due to their system time being slightly off.

It appears to be that way:

Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)

I used the ISO image to install, Manjaro Gnome, last week on 2 systems and it was disabled…

I use KDE. Possibly an oversight on the Gnome ISO?

I’ve just updated the GNOME ISO profile to enable systemd-timesyncd by default.


Cinnamon is not enabled and never has been.

It is now. :wink:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.