無法顯示省略號(22EF)


#1

大家好。

我在隨身碟上安裝了 Manjaor-xfce-17.1,使用上覺得一切都好,但有一個小問題感覺有點困擾。就是我的系統無法顯示 「⋯⋯」這個字元——編碼:22EF,省略號。請問大家是否知道這是出了什麼問題?可以如何解決?

系統語系設定台灣中文,也已安裝系統建議的語系檔,如下圖:
%E8%9E%A2%E5%B9%95%E5%BF%AB%E7%85%A7_2018-08-09_09-09-57

這個問題出現在各個地方,Chromium、Firefox、Mousepad 文字編輯器、系統選單等各地:
%E8%9E%A2%E5%B9%95%E5%BF%AB%E7%85%A7_2018-08-09_11-13-29

找到字元編碼測試網站,測試的結果是系統裡安裝的所有字型都無法顯示:


#2

Did you install fonts like wqy-zenhei and the apps language pack like firefox-i18n-zh-tw?
You need to look what fonts are available or are required to display.


#3

Yes, wqy-zenhei and the apps language pack are installed, as the 4th pic showed.The thing I don’t understand is ,all fonts that show 22EF just don’t work on this system,like wqy-zenhei.


#4

I don’t know then. Perhaps, just perhaps, some foreign websites in Chinese language use zh_CN only? What is the (Chinese) link so I can check that out?


#5

Thank you for the help.:grinning:

As this pic,this is from Facebook,it uses zh_TW,and can’t show 22EF:
%E8%9E%A2%E5%B9%95%E5%BF%AB%E7%85%A7_2018-08-09_11-13-29


#6

And not only in browser, but also in the system.This is from “Menu”,can’t show 22EF too:
menu


#7

Sorry again. don’t have facebook and don’t have manjaro xfce.
But firefox shows up Chinese text (zh_CN) very well for me.

As do zh_TW text.


#8

Thank you.

Yes, Manjaro shows up Chinese text well, both zh_TW and zh_CN. Firefox, Chrome, Mousepad, anywhere in Manjaro. But just the unicode character ‘MIDLINE HORIZONTAL ELLIPSIS’ (U+22EF), it doesn’t show up in my Manjaro system.

All the fonts I install in my system don’t show it up. All the apps in my system don’t show it up. That’s the problem.:roll_eyes::roll_eyes:


#9

‘MIDLINE HORIZONTAL ELLIPSIS’ (U+22EF) is a mathematical (logical?) symbol.

Other than zh_TW, do you also have en_US ?
You can check with

$ localectl list-locales

If it is not there,

# gedit /etc/locale.gen

Uncomment line “en_US.utf8”, then

# locale-gen

Verify again with

$ localectl list-locales

Reboot.
Let us know if the symbol turns out this time.
Good luck.


#10

Actually I have en_US already in the beginning.

%E8%9E%A2%E5%B9%95%E5%BF%AB%E7%85%A7_2018-08-10_11-28-47


#11

I looked at the locale.gen file too. “en_US.UTF-8” line is uncomment already.

%E8%9E%A2%E5%B9%95%E5%BF%AB%E7%85%A7_2018-08-10_11-29-41


#12

Okay. I really really cannot continue then.
But good luck. And let us know if you find a way.
Cheers.

保重。


#13

Thank you.

我盡量找找看解決方法了。
謝謝你。 :blush:


#14

I got the solution, and it’s so simple.
Just install Google Noto Fonts.
:sweat_smile:

Manjaro GNOME is fine for this(it include Google Noto Fonts maybe), but there is “can’t wake up” problem.

I’am using Manjaro XFCE.


#15

Good to hear.
I do have noto fonts installed.
Cheers.


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.