2019-05-04 - Issue with Firefox extensions becoming disabled (Solved, update to 66.0.5)

#1

UPDATE: Firefox 66.0.5 is in all branches. Please update.


You may or may not have heard that there are issues with extensions in Mozilla browsers disabling themselves:

This is not a Manjaro issue and we can't fix it.

A fix is in progress:


Please be patient while Mozilla fixes the issue. If it also requires building a new Firefox/Thunderbird/etc. then the fix will take longer.

If you can't be patient or would like to vent your frustration then you can use the Rant thread:


MOZILLA'S HOTFIX EXTENSION/ADDON:
https://storage.googleapis.com/moz-fx-normandy-prod-addons/extensions/hotfix-update-xpi-intermediate%40mozilla.com-1.0.2-signed.xpi

This is a direct link to Mozilla's "hotfix" extension/addon which updates the expired intermediate certificate.


29 Likes
[solved]Firefox consuming about 50% CPU
Firefox is missing all extensions/addons and cannot download them anymore
#2

If you are lucky like me (who doesn't faced this issue, my all add-ons are active) you can share your joy here.

1 Like
#3

Incomprehensible that it happened, just happened. Mozilla is working on it.
:dizzy_face:

#4

My firefox-developer-edition working just fine. (xpinstall.signatures.required = false)
Regular ff not :sunglasses:

#6

Firefox on Twitter:
So sorry for the issue we’re having with add-ons right now!
We’re working hard to fix it and will keep you updated.
:wink:

If you do not want to do without your installed add-ons, you can fix the problem with a fix: In the browser configuration (about: config) set the value xpinstall.signatures.required to false (then restart the browser). Thus, the add-on
ons ons - however, under about: addons they are still marked with a warning that they could not be verified for use. Attention: Turning off this feature is a security risk! You should definitely set it back to true later.

#7

This will may only work in Beta/Developer/Nightly builds. It won't (shouldn't?) might not have an effect in Release builds.

1 Like
#8

Interesting time. 12:50 p.m. utc. I am still thinking it's only 11:15 a.m. utc :thinking:

1 Like
#9

"Allow Firefox to install and run studies" work ! My extensions are back.

4 Likes
#10

Now they're back you can disable that setting - if you want to.

#11

Yes. I disable all "Firefox Data Collection"

2 Likes
#12
xpinstall.signatures.required=false

This worked fine for me in firefox-kde release build.

2 Likes
#13

No problems here so far.
Netrunner Rolling - upstream Firefox using portal-kde - ublock origin - plasma integration - facebook containers:

#14

@jonathon
Thx for the tip! :slightly_smiling_face:

I have another Firefox problem on one of my fresh installs, there's only english language and in preferences there's no languages listed at all, and when you try to add - list is empty (it's all regardless if you have i18n packages installed or not).

Any ideas?

#15

Start a new thread rather than hijacking an announcement thread for an unrelated issue?

Be patient and wait for them to come back too.

#16

Just thought maybe it's connected somehow, ok :upside_down_face:


But speaking on this particular topic - i had problems of unable to install any addon ~ hour ago, fixed itself now :face_with_raised_eyebrow:

1 Like
#17

For now, I only have one system affected: Manjaro on desktop. Works fine on Windows 10 on desktop and Manjaro on laptop.

Huh. Oh well.

#18

not unrelated, language packs are signed too.

2 Likes
Firefox unable to select / add languages
#19

Well, that was my point...
Since that have never happened before, and weirdly enough haven't happen on existing installations :slight_smile:

But still here's already created new topic...

So it's seems that best option for now is to wait

@Frog
That's seriously creepy, but i also have this only on desktop, 2 laptops are fine...what the hell :grin:
All of them are on Manjaro

1 Like
#20

I had high CPU usage with the extensions disabled yesterday, today go back to normal.

#21

Fix is ​​coming